File qt-dab.spec of Package qt-dab
#
# spec file for package qt-dab
#
# Copyright (c) 2014-2025 Wojciech Kazubski <wk@ire.pw.edu.pl>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.links2linux.org/
#
Name: qt-dab
Version: 6.9
Release: 0
License: GPL-2.0-or-later
Summary: Simple DAB/DAB+ receiver
Url: http://www.sdr-j.tk/index.html
Group: Productivity/Multimedia/Other
Source0: https://github.com/JvanKatwijk/%{name}/archive/refs/tags/Qt-DAB-%{version}.tar.gz#/%{name}-Qt-DAB-%{version}.tar.gz
Patch1: %{name}-6.9-use-qwt6-qt6.patch
BuildRequires: cmake
BuildRequires: filesystem
BuildRequires: gcc-c++
BuildRequires: qt6-base-devel
BuildRequires: qt6-multimedia-devel
BuildRequires: qwt6-qt6-devel >= 6.1
BuildRequires: pkgconfig(fftw3)
BuildRequires: hackrf-devel
BuildRequires: pkgconfig(libairspy)
BuildRequires: pkgconfig(librtlsdr)
BuildRequires: sdrplay-devel
BuildRequires: pkgconfig(portaudio-2.0)
BuildRequires: pkgconfig(samplerate)
BuildRequires: pkgconfig(sndfile)
BuildRequires: libusb-1_0-devel
BuildRequires: libfaad-devel
BuildRequires: update-desktop-files
%description
This is the implementation of a -relatively simple DAB/DAB+ receiver.
The receiver supports terrestrial DAB reception with as input either
the stream from a dabstick or a (prerecorded) file, and it will
output through the default soundcard.
%prep
%setup -q -n %{name}-Qt-DAB-%{version}
%patch -P 1 -p1 -b .aaaa
#fix docs permissions
chmod a-x AUTHORS
chmod a-x COPYING
chmod a-x README.md
%build
cd %{name}-%{version}
%cmake \
-DAIRSPY=ON \
-DHACKRF=ON \
-DRTLSDR=ON \
-DRTLTCP=ON \
-DSDRPLAY=ON
%cmake_build
%install
cd %{name}-%{version}
%cmake_install
# move binary to /usr/bin and rename it
mkdir -p %{buildroot}%{_bindir}
mv %{buildroot}/usr/Qt-DAB %{buildroot}%{_bindir}/%{name}-6.9
# install desktop file
%suse_update_desktop_file -G Qt-DAB -i %{name}-6.9 AudioVideo Tuner
# install icon
install -Dpm 0644 %{name}-6.9.png %{buildroot}%{_datadir}/pixmaps/%{name}-6.9.png
%check
%files
%doc AUTHORS README.md
%license COPYING
%{_bindir}/%{name}-%{version}
%{_datadir}/applications/%{name}-6.9.desktop
%{_datadir}/pixmaps/%{name}-6.9.png
%changelog