File handbrake.spec of Package handbrake
#
# spec file for package handbrake
#
# Copyright (c) 2012 Pascal Bleser <pascal.bleser@opensuse.org>
# Copyright (c) 2020 B1 Systems GmbH, Vobhurg, Germany
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: handbrake
Summary: Multithreaded Video Transcoder
Version: 1.8.2
Release: 0
License: GPL-2.0-or-later
URL: http://handbrake.fr/
Source0: https://github.com/HandBrake/HandBrake/releases/download/%{version}/HandBrake-%{version}-source.tar.bz2#/%{name}-%{version}.tar.bz2
Source1: https://github.com/HandBrake/HandBrake/releases/download/%{version}/HandBrake-%{version}-source.tar.bz2.sig#/%{name}-%{version}.tar.bz2.sig
Source2: https://keyserver.ubuntu.com/pks/lookup?op=get&search=0x1629c061b3dde7eb4ae34b81021db8b44e4a8645#/%{name}.keyring
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: cargo
BuildRequires: gcc-c++
BuildRequires: cargo-c
BuildRequires: cmake
BuildRequires: git-core
BuildRequires: libtool
BuildRequires: m4
BuildRequires: make
BuildRequires: meson
BuildRequires: nasm
BuildRequires: python3
BuildRequires: pkgconfig(SvtAv1Enc)
BuildRequires: pkgconfig(bzip2)
BuildRequires: pkgconfig(dav1d)
BuildRequires: pkgconfig(dovi)
BuildRequires: pkgconfig(dvdnav)
BuildRequires: pkgconfig(dvdread)
BuildRequires: pkgconfig(egl)
BuildRequires: pkgconfig(ffnvcodec)
BuildRequires: pkgconfig(fontconfig)
BuildRequires: pkgconfig(freetype2)
BuildRequires: pkgconfig(fribidi)
BuildRequires: pkgconfig(gtk4)
BuildRequires: pkgconfig(gudev-1.0)
BuildRequires: pkgconfig(jansson)
BuildRequires: pkgconfig(lame)
BuildRequires: pkgconfig(libass)
BuildRequires: pkgconfig(libavcodec)
BuildRequires: pkgconfig(libavfilter)
BuildRequires: pkgconfig(libavformat)
BuildRequires: pkgconfig(libavutil)
BuildRequires: pkgconfig(libbluray)
BuildRequires: pkgconfig(libdrm)
BuildRequires: pkgconfig(libjpeg)
BuildRequires: pkgconfig(liblzma)
BuildRequires: pkgconfig(libmpeg2)
BuildRequires: pkgconfig(librepo)
BuildRequires: pkgconfig(libva)
BuildRequires: pkgconfig(numa)
BuildRequires: pkgconfig(ogg)
BuildRequires: pkgconfig(samplerate)
BuildRequires: pkgconfig(speex)
BuildRequires: pkgconfig(theora)
BuildRequires: pkgconfig(vorbis)
BuildRequires: pkgconfig(vpl)
BuildRequires: pkgconfig(vpx)
BuildRequires: pkgconfig(x264)
BuildRequires: pkgconfig(x265)
%description
HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded video
transcoder.
%prep
%autosetup -n HandBrake-%{version}
# Use system libraries in place of bundled ones
for module in fdk-aac ffmpeg libdovi libdav1d libdvdnav libdvdread libbluray libvpl nvdec nvenc svt-av1 x265; do
sed -i -e "/MODULES += contrib\/$module/d" make/include/main.defs
done
%build
export CFLAGS="%{optflags} -I%{_includedir}/vpl -I%{_includedir}/ffmpeg"
./configure \
--disable-df-fetch \
--disable-df-verify \
--verbose \
--harden \
--lto \
--optimize=speed \
--prefix=%{_prefix} \
--enable-gtk \
--enable-ffmpeg-aac \
--enable-asm \
--enable-x265 \
--enable-nvdec \
--enable-nvenc \
--enable-libdovi \
--enable-vce \
--enable-numa \
--enable-fdk-aac \
--enable-qsv \
--force
pushd build
%make_build
popd
%install
%make_install
%fdupes %{buildroot}
%files
%changelog