File winff.spec of Package winff (Revision 2)

Currently displaying revision 2 , Show latest

92
 
1
#
2
# spec file for package winff
3
#
4
# Copyright (c) 2012 Pascal Bleser <pascal.bleser@opensuse.org>
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.links2linux.org/
16
17
Name:           winff
18
Version:        1.5.2
19
Release:        0
20
License:        GPL-3.0+
21
Summary:        Multimedia File Converter
22
Url:            http://winff.org
23
Group:          Productivity/Multimedia/Video/Editors and Convertors
24
Source0:        https://winff.googlecode.com/files/WinFF-1.5.2-source.tar.gz
25
Source1:        winff.desktop
26
BuildRequires:  atk-devel
27
BuildRequires:  lazarus
28
BuildRequires:  update-desktop-files
29
BuildRequires:  pkgconfig(cairo)
30
BuildRequires:  pkgconfig(gtk+-2.0)
31
BuildRequires:  pkgconfig(pango)
32
Requires:       ffmpeg
33
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
34
35
%description
36
WinFF is a GUI for the command line video converter, FFMPEG. It will convert
37
any video file that FFmpeg will convert. WinFF does multiple files in multiple
38
formats at one time. You can for example convert mpeg's, flv's, and mov's, all
39
into avi's all at once.
40
41
%lang_package
42
43
%prep
44
%setup -q -c winff
45
# rmove exec bits
46
chmod a-x {README.txt,changelog.txt,AUTHORS,README-Presets.txt}
47
48
%build
49
lazbuild winff.lpr --ws=gtk2
50
51
%install
52
install -D -m 0755 winff "%{buildroot}%{_bindir}/winff"
53
install -d -m 0755 "%{buildroot}%{_datadir}/winff"
54
find . -name '*.xml' \
55
    -exec install -D -m0644 {} "%{buildroot}%{_datadir}/winff/" \;
56
install -D -m0644 "%{SOURCE1}" "%{buildroot}%{_datadir}/applications/%{name}.desktop"
57
for s in 16 24 32 48; do
58
    install -D -m0644 "winff-icons/${s}x${s}/winff.png" \
59
        "%{buildroot}%{_datadir}/icons/hicolor/${s}x${s}/apps/winff.png"
60
done
61
62
install -d -m0755 "%{buildroot}%{_datadir}/winff/languages"
63
find . -name '*.po' -exec install -D -m0644 {} "%{buildroot}%{_datadir}/winff/languages/" \;
64
65
%suse_update_desktop_file -r "%{name}" AudioVideo AudioVideoEditing
66
67
L="$PWD/%{name}.lang"; echo -n >"$L"
68
B="%{_datadir}/winff/languages"
69
pushd "%{buildroot}$B"
70
/bin/ls -1 winff.*.po | while read po; do
71
    l="${po%.po}"
72
    l="${l#winff.}"
73
    echo "%lang($l) $B/$po" >>"$L"
74
done
75
popd
76
77
%files
78
%defattr(-,root,root)
79
%doc AUTHORS *.txt
80
%{_bindir}/winff
81
%dir %{_datadir}/winff
82
%dir %{_datadir}/winff/languages
83
%lang(en) %{_datadir}/winff/languages/winff.po
84
%config %{_datadir}/winff/presets.xml
85
%{_datadir}/icons/*/*/apps/winff.*
86
%{_datadir}/applications/%{name}.desktop
87
88
%files lang -f "%{name}.lang"
89
%defattr(-,root,root)
90
91
%changelog
92