File makemkv.spec of Package MakeMKV (Revision 34)
Currently displaying revision 34 , Show latest
171
1
#
2
# spec file for package makemkv
3
#
4
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
%define majordriveio 0
20
%define libdriveio libdriveio
21
%define libnamedriveio %{libdriveio}%{majordriveio}
22
%define majormakemkv 1
23
%define libmakemkv libmakemkv
24
%define libnamemakemkve %{libmakemkv}%{majormakemkv}
25
%define majormmbd 0
26
%define libmmbd libmmbd
27
%define libnamemmbd %{libmmbd}%{majormmbd}
28
29
Name: makemkv
30
Summary: DVD and BlueRay Ripping tool
31
Version: 1.9.5
32
Release: 0.pm.1
33
License: see eula_en_linux.txt
34
Group: Productivity/Multimedia/Video/Editors and Convertors
35
Url: http://www.makemkv.com
36
Source0: %{name}-oss-%{version}.tar.xz
37
Source1: %{name}-bin-%{version}.tar.xz
38
Patch0: makemkv-oss-1.9.0.diff
39
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
40
Requires: %{libnamedriveio} = %{version}-%{release}
41
Requires: %{libnamemakemkve} = %{version}-%{release}
42
Requires: %{libnamemmbd} = %{version}-%{release}
43
BuildRequires: libopenssl-devel
44
BuildRequires: libexpat-devel
45
%if 0%{?suse_version} >= 1320
46
BuildRequires: pkgconfig(Qt5Core)
47
BuildRequires: pkgconfig(Qt5DBus)
48
BuildRequires: pkgconfig(Qt5Gui)
49
BuildRequires: pkgconfig(Qt5Widgets)
50
%else
51
BuildRequires: pkgconfig(QtCore)
52
BuildRequires: pkgconfig(QtGui)
53
BuildRequires: pkgconfig(QtDBus)
54
%endif
55
BuildRequires: pkgconfig(libavcodec)
56
BuildRequires: pkgconfig(libavutil)
57
BuildRequires: update-desktop-files
58
ExclusiveArch: i586 x86_64
59
60
%description
61
MakeMKV is your one-click solution to convert video that you own into
62
free and patents-unencumbered format that can be played everywhere.
63
MakeMKV is a format converter, otherwise called "transcoder". It
64
converts the video clips from proprietary (and usually encrypted)
65
disc into a set of MKV files, preserving most information but not
66
changing it in any way. The MKV format can store multiple video/audio
67
tracks with all meta-information and preserve chapters. There are many
68
players that can play MKV files nearly on all platforms, and there are
69
tools to convert MKV files to many formats, including DVD and Blu-ray
70
discs.
71
72
Additionally MakeMKV can instantly stream decrypted video without
73
intermediate conversion to wide range of players, so you may watch
74
Blu-ray and DVD discs with your favorite player on your favorite OS
75
or on your favorite device.
76
77
* Reads DVD and Blu-ray discs
78
* Reads Blu-ray discs protected with latest versions of AACS and BD+
79
* Preserves all video and audio tracks, including HD audio
80
* Preserves chapters information
81
* Preserves all meta-information (track language, audio type)
82
* Fast conversion - converts as fast as your drive can read data.
83
* No additional software is required for conversion or decryption.
84
* Available for Windows, Mac OS X and Linux
85
* Functionality to open DVD discs is free and will always stay free.
86
* All features (including Blu-ray decryption and processing) are free during BETA.
87
88
89
%package -n %{libnamedriveio}
90
Group: System/Libraries
91
Summary: MakeMKV %{libdriveio}
92
Provides: %{libdriveio} = %{version}-%{release}
93
94
%description -n %{libnamedriveio}
95
MakeMKV %{libdriveio} shared library
96
97
98
%package -n %{libnamemakemkve}
99
Group: System/Libraries
100
Summary: MakeMKV %{libmakemkv}
101
Provides: %{libmakemkv} = %{version}-%{release}
102
103
%description -n %{libnamemakemkve}
104
MakeMKV %{libmakemkv} shared library
105
106
107
%package -n %{libnamemmbd}
108
Group: System/Libraries
109
Summary: MakeMKV %{libmmbd}
110
Provides: %{libmmbd} = %{version}-%{release}
111
112
%description -n %{libnamemmbd}
113
MakeMKV %{libmmbd} shared library
114
115
116
%prep
117
%setup -q -n %{name}-oss-%{version}
118
%patch0 -p0
119
120
%build
121
%configure
122
%{__make} %{?jobs:-j%{jobs}}
123
124
%install
125
%makeinstall
126
%suse_update_desktop_file -c makemkv makemkv "makemkv" makemkv makemkv.png AudioVideo AudioVideoEditing
127
tar xaf %{SOURCE1}
128
%ifarch x86_64
129
%{__install} -m 755 %{name}-bin-%{version}/bin/amd64/makemkvcon %{buildroot}%{_bindir}/
130
%else
131
%{__install} -m 755 %{name}-bin-%{version}/bin/i386/makemkvcon %{buildroot}%{_bindir}/
132
%{__install} -m 755 %{name}-bin-%{version}/bin/i386/mmdtsdec %{buildroot}%{_bindir}/
133
%endif
134
135
136
%post -n %{libnamedriveio} -p /sbin/ldconfig
137
%postun -n %{libnamedriveio} -p /sbin/ldconfig
138
139
%post -n %{libnamemakemkve} -p /sbin/ldconfig
140
%postun -n %{libnamemakemkve} -p /sbin/ldconfig
141
142
%post -n %{libnamemmbd} -p /sbin/ldconfig
143
%postun -n %{libnamemmbd} -p /sbin/ldconfig
144
145
146
%files
147
%defattr(-,root,root)
148
%doc %{name}-bin-%{version}/src/eula_en_linux.txt
149
%{_bindir}/makemkv
150
%{_bindir}/makemkvcon
151
%ifarch i586
152
%{_bindir}/mmdtsdec
153
%endif
154
%{_datadir}/icons/hicolor
155
%{_datadir}/applications/makemkv.desktop
156
157
%files -n %{libnamedriveio}
158
%defattr(-,root,root)
159
%{_libdir}/%{libdriveio}.so.%{majordriveio}*
160
161
%files -n %{libnamemakemkve}
162
%defattr(-,root,root)
163
%{_libdir}/%{libmakemkv}.so.%{majormakemkv}*
164
165
%files -n %{libnamemmbd}
166
%defattr(-,root,root)
167
%{_libdir}/%{libmmbd}.so.%{majormmbd}*
168
169
170
%changelog
171