File psi+-iconsets.spec of Package psi+-iconsets (Revision 87132ef5b502facb625a808871df255a)

Currently displaying revision 87132ef5b502facb625a808871df255a , Show latest

96
 
1
#
2
# spec file for package psi+-iconsets
3
#
4
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
Name:           psi+-iconsets
20
Url:            http://code.google.com/p/psi-dev/
21
Version:        20130107
22
Release:        0
23
Summary:        Icons for Psi
24
License:        GPL-2.0; CC-BY-ND-3.0
25
Group:          Productivity/Networking/Talk/Clients
26
Requires:       psi+
27
Source0:        psi-plus-main-%{version}.tar.xz
28
Source1:        psi-plus-resources-1.tar.xz
29
BuildArch:      noarch
30
BuildRequires:  fdupes
31
BuildRequires:  xz
32
33
%define iconspath %{_datadir}/psi-plus/iconsets
34
35
%prep
36
%setup -q -n psi-plus-main-%{version} -b 1
37
38
%build
39
40
%install
41
install -d -m 0755 %{buildroot}/%{iconspath}
42
43
for DIR in activities/default affiliations/default clients/default moods/default; do
44
    DEST="%{buildroot}/%{iconspath}/$DIR/"
45
    install -d -m 0755 "$DEST"
46
    install -m 0644 -t "$DEST" iconsets/"$DIR"/icondef.xml
47
    install -m 0644 -t "$DEST" iconsets/"$DIR"/*.png
48
done
49
50
install -m 0644 -t "%{buildroot}/%{iconspath}/clients/default/" 'iconsets/clients/default/FP_Freeware License.txt'
51
52
for DIR in activities affiliations clients emoticons moods roster system; do
53
    DEST="%{buildroot}/%{iconspath}/$DIR/"
54
    install -d -m 0755 "$DEST"
55
    install -m 0644 -t "$DEST" ../psi-plus-resources-1/iconsets/"$DIR"/*.jisp
56
done
57
58
%fdupes $RPM_BUILD_ROOT/%{iconspath}
59
60
%description
61
Some additional icons for Psi - emoticons.
62
63
%files
64
%defattr(-,root,root)
65
%dir %{_datadir}/psi-plus
66
%dir %{iconspath}
67
%dir %{iconspath}/activities
68
%dir %{iconspath}/activities/default
69
%dir %{iconspath}/affiliations
70
%dir %{iconspath}/affiliations/default
71
%dir %{iconspath}/clients
72
%dir %{iconspath}/clients/default
73
%dir %{iconspath}/emoticons
74
%dir %{iconspath}/moods
75
%dir %{iconspath}/moods/default
76
%dir %{iconspath}/roster
77
%dir %{iconspath}/system
78
%{iconspath}/activities/*.jisp
79
%{iconspath}/affiliations/*.jisp
80
%{iconspath}/clients/*.jisp
81
%{iconspath}/emoticons/*.jisp
82
%{iconspath}/moods/*.jisp
83
%{iconspath}/roster/*.jisp
84
%{iconspath}/system/*.jisp
85
%{iconspath}/activities/default/icondef.xml
86
%{iconspath}/affiliations/default/icondef.xml
87
%{iconspath}/clients/default/icondef.xml
88
%{iconspath}/moods/default/icondef.xml
89
%{iconspath}/clients/default/FP_Freeware?License.txt
90
%{iconspath}/activities/default/*.png
91
%{iconspath}/affiliations/default/*.png
92
%{iconspath}/clients/default/*.png
93
%{iconspath}/moods/default/*.png
94
95
%changelog
96