File lightspark.spec of Package lightspark (Revision a73a2070a7009fb0d97b521c59e8400d)
Currently displaying revision a73a2070a7009fb0d97b521c59e8400d , Show latest
140
1
#
2
# spec file for package lightspark
3
#
4
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
%bcond_without ffmpeg
20
%bcond_without rtmp
21
22
Name: lightspark
23
Version: 0.7.2.99+git20160105.1059
24
Release: 0
25
Summary: Modern, free, open-source flash player implementation
26
License: LGPL-3.0+
27
Group: Productivity/Multimedia/Other
28
Url: https://launchpad.net/lightspark/
29
Source0: lightspark.tar.xz
30
BuildRequires: boost-devel
31
BuildRequires: cmake
32
BuildRequires: desktop-file-utils
33
BuildRequires: gcc-c++
34
BuildRequires: gettext-tools
35
BuildRequires: hicolor-icon-theme
36
BuildRequires: libjpeg-devel
37
BuildRequires: llvm-devel >= 2.8
38
BuildRequires: nasm
39
BuildRequires: pkgconfig(cairo)
40
BuildRequires: pkgconfig(gdk-2.0)
41
BuildRequires: pkgconfig(gl)
42
BuildRequires: pkgconfig(glew)
43
BuildRequires: pkgconfig(glib-2.0)
44
BuildRequires: pkgconfig(glibmm-2.4)
45
BuildRequires: pkgconfig(gmodule-2.0)
46
BuildRequires: pkgconfig(gthread-2.0)
47
BuildRequires: pkgconfig(gtk+-2.0)
48
BuildRequires: pkgconfig(libcurl)
49
BuildRequires: pkgconfig(liblzma)
50
BuildRequires: pkgconfig(libpcre)
51
BuildRequires: pkgconfig(libpng)
52
BuildRequires: pkgconfig(libxml++-2.6) >= 2.33.1
53
BuildRequires: pkgconfig(pango)
54
BuildRequires: pkgconfig(pangocairo)
55
BuildRequires: pkgconfig(sdl)
56
BuildRequires: pkgconfig(SDL_mixer)
57
BuildRequires: pkgconfig(x11)
58
BuildRequires: pkgconfig(zlib)
59
Recommends: %{_bindir}/gnash
60
%if 0%{?suse_version} > 1310
61
BuildRequires: pkgconfig(tinfo)
62
%endif
63
%if %{with rtmp}
64
BuildRequires: pkgconfig(libcrypto)
65
BuildRequires: pkgconfig(librtmp)
66
BuildRequires: pkgconfig(libssl)
67
%endif
68
%if %{with ffmpeg}
69
BuildRequires: pkgconfig(libavcodec)
70
BuildRequires: pkgconfig(libavformat)
71
BuildRequires: pkgconfig(libavutil)
72
%endif
73
74
%description
75
Lightspark is a modern, free, open-source flash player implementation.
76
77
%package plugin
78
Summary: NPAPI plugin for lightspark
79
Group: Productivity/Multimedia/Other
80
Requires: %{name} = %{version}
81
Enhances: browser(npapi)
82
Conflicts: flash-player
83
Conflicts: gnash-browser-plugin
84
85
%description plugin
86
NPAPI plugin for lightspark.
87
88
%prep
89
%setup -q -n %{name}
90
91
%build
92
export CFLAGS='%{optflags}'
93
export CXXFLAGS='%{optflags}'
94
mkdir build
95
cd build
96
cmake -DCMAKE_BUILD_WITH_INSTALL_RPATH=1 \
97
-DAUDIO_BACKEND=sdl \
98
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
99
-DLIB_SUFFIX=$(echo %{_lib} | cut -b4-) \
100
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
101
-DPLUGIN_DIRECTORY=%{_libdir}/browser-plugins \
102
-DENABLE_LIBAVCODEC=%{?with_ffmpeg:YES}%{!?with_ffmpeg:NO} \
103
-DENABLE_RTMP=%{?with_rtmp:YES}%{!?with_rtmp:NO} ..
104
make %{?_smp_mflags}
105
106
%install
107
cd build
108
%make_install
109
cd ..
110
%find_lang %{name}
111
rm -f %{buildroot}%{_libdir}/%{name}/lib%{name}.so
112
# Not in hicolor theme (lp#1000840)
113
rm -rf %{buildroot}%{_datadir}/icons/hicolor/20x20
114
115
%post
116
%icon_theme_cache_post
117
%desktop_database_post
118
119
%postun
120
%desktop_database_postun
121
%icon_theme_cache_postun
122
123
%files -f %{name}.lang
124
%defattr(0644,root,root,0755)
125
%doc COPYING.LESSER ChangeLog
126
%config(noreplace) %{_sysconfdir}/xdg/lightspark.conf
127
%attr(0755,root,root) %{_bindir}/lightspark
128
%attr(0755,root,root) %{_bindir}/tightspark
129
%{_datadir}/lightspark
130
%{_datadir}/applications/lightspark.desktop
131
%{_datadir}/icons/hicolor/*/*/*
132
%{_mandir}/man1/lightspark.1*
133
%{_libdir}/lightspark
134
135
%files plugin
136
%defattr(0644,root,root,0755)
137
%{_libdir}/browser-plugins/liblightsparkplugin.so
138
139
%changelog
140