File lightspark.spec of Package lightspark (Revision 5843d519f77305a1f0936ec65792bfd8)
Currently displaying revision 5843d519f77305a1f0936ec65792bfd8 , Show latest
139
1
#
2
# spec file for package lightspark
3
#
4
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
%bcond_without ffmpeg
20
%bcond_without rtmp
21
22
Name: lightspark
23
Version: 0.7.2.99+git20151107.1914
24
Release: 0
25
Summary: Modern, free, open-source flash player implementation
26
License: LGPL-3.0+
27
Group: Productivity/Multimedia/Other
28
Url: https://launchpad.net/lightspark/
29
Source0: lightspark.tar.xz
30
BuildRequires: boost-devel
31
BuildRequires: cmake
32
BuildRequires: desktop-file-utils
33
BuildRequires: gcc-c++
34
BuildRequires: gettext-tools
35
BuildRequires: hicolor-icon-theme
36
BuildRequires: libjpeg-devel
37
BuildRequires: llvm-devel >= 2.8
38
BuildRequires: nasm
39
BuildRequires: pkgconfig(cairo)
40
BuildRequires: pkgconfig(gdk-2.0)
41
BuildRequires: pkgconfig(gl)
42
BuildRequires: pkgconfig(glew)
43
BuildRequires: pkgconfig(glib-2.0)
44
BuildRequires: pkgconfig(glibmm-2.4)
45
BuildRequires: pkgconfig(gmodule-2.0)
46
BuildRequires: pkgconfig(gthread-2.0)
47
BuildRequires: pkgconfig(gtk+-2.0)
48
BuildRequires: pkgconfig(libcurl)
49
BuildRequires: pkgconfig(liblzma)
50
BuildRequires: pkgconfig(libpcre)
51
BuildRequires: pkgconfig(libpng)
52
BuildRequires: pkgconfig(libxml++-2.6) >= 2.33.1
53
BuildRequires: pkgconfig(pango)
54
BuildRequires: pkgconfig(pangocairo)
55
BuildRequires: pkgconfig(sdl)
56
BuildRequires: pkgconfig(x11)
57
BuildRequires: pkgconfig(zlib)
58
Recommends: %{_bindir}/gnash
59
%if 0%{?suse_version} > 1310
60
BuildRequires: pkgconfig(tinfo)
61
%endif
62
%if %{with rtmp}
63
BuildRequires: pkgconfig(libcrypto)
64
BuildRequires: pkgconfig(librtmp)
65
BuildRequires: pkgconfig(libssl)
66
%endif
67
%if %{with ffmpeg}
68
BuildRequires: pkgconfig(libavcodec)
69
BuildRequires: pkgconfig(libavformat)
70
BuildRequires: pkgconfig(libavutil)
71
%endif
72
73
%description
74
Lightspark is a modern, free, open-source flash player implementation.
75
76
%package plugin
77
Summary: NPAPI plugin for lightspark
78
Group: Productivity/Multimedia/Other
79
Requires: %{name} = %{version}
80
Enhances: browser(npapi)
81
Conflicts: flash-player
82
Conflicts: gnash-browser-plugin
83
84
%description plugin
85
NPAPI plugin for lightspark.
86
87
%prep
88
%setup -q -n %{name}
89
90
%build
91
export CFLAGS='%{optflags}'
92
export CXXFLAGS='%{optflags}'
93
mkdir build
94
cd build
95
cmake -DCMAKE_BUILD_WITH_INSTALL_RPATH=1 \
96
-DAUDIO_BACKEND=sdl \
97
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
98
-DLIB_SUFFIX=$(echo %{_lib} | cut -b4-) \
99
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
100
-DPLUGIN_DIRECTORY=%{_libdir}/browser-plugins \
101
-DENABLE_LIBAVCODEC=%{?with_ffmpeg:YES}%{!?with_ffmpeg:NO} \
102
-DENABLE_RTMP=%{?with_rtmp:YES}%{!?with_rtmp:NO} ..
103
make %{?_smp_mflags}
104
105
%install
106
cd build
107
%make_install
108
cd ..
109
%find_lang %{name}
110
rm -f %{buildroot}%{_libdir}/%{name}/lib%{name}.so
111
# Not in hicolor theme (lp#1000840)
112
rm -rf %{buildroot}%{_datadir}/icons/hicolor/20x20
113
114
%post
115
%icon_theme_cache_post
116
%desktop_database_post
117
118
%postun
119
%desktop_database_postun
120
%icon_theme_cache_postun
121
122
%files -f %{name}.lang
123
%defattr(0644,root,root,0755)
124
%doc COPYING.LESSER ChangeLog
125
%config(noreplace) %{_sysconfdir}/xdg/lightspark.conf
126
%attr(0755,root,root) %{_bindir}/lightspark
127
%attr(0755,root,root) %{_bindir}/tightspark
128
%{_datadir}/lightspark
129
%{_datadir}/applications/lightspark.desktop
130
%{_datadir}/icons/hicolor/*/*/*
131
%{_mandir}/man1/lightspark.1*
132
%{_libdir}/lightspark
133
134
%files plugin
135
%defattr(0644,root,root,0755)
136
%{_libdir}/browser-plugins/liblightsparkplugin.so
137
138
%changelog
139