File lightspark.spec of Package lightspark (Revision 4d7e89a182203578a240f8edb953c6cc)
Currently displaying revision 4d7e89a182203578a240f8edb953c6cc , Show latest
145
1
#
2
# spec file for package lightspark
3
#
4
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
# Copyright (c) 2012 Benjamin Denisart <p.drouand@gmail.com>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
#
16
17
Name: lightspark
18
Version: 0.6.0+git20120606
19
Release: 0
20
License: LGPL-3.0+
21
Summary: SWF desktop reader
22
Url: http://lightspark.github.com/
23
Group: Productivity/Multimedia/Other
24
Source0: %{name}-0.6.0%2Bgit20120606.tar.bz2
25
BuildRequires: boost-devel
26
BuildRequires: cmake
27
BuildRequires: curl-devel
28
BuildRequires: libffmpeg-devel
29
BuildRequires: freetype2-devel
30
BuildRequires: gcc-c++
31
BuildRequires: glew-devel
32
BuildRequires: hicolor-icon-theme
33
BuildRequires: libjpeg62-devel
34
BuildRequires: libpulse-devel
35
BuildRequires: libxml++-devel
36
BuildRequires: llvm-devel
37
BuildRequires: nasm
38
BuildRequires: pcre-devel
39
BuildRequires: pkg-config
40
BuildRequires: update-desktop-files
41
BuildRequires: zlib-devel
42
BuildRequires: pkgconfig(gtk+-2.0)
43
Requires: liberation-fonts
44
Requires: lightspark-common
45
Recommends: %{name}-lang
46
BuildRoot: %{_tmppath}/%{name}-%{version}-build
47
%lang_package
48
49
%description
50
Lightspark is an LGPL-3.0+ licensed Flash player and browser
51
plugin written in C++/C that runs on Linux. It aims to support
52
Adobe's newer Flash formats and AVM2 virtual machine.
53
54
%package browser-plugin
55
Summary: This package contains the browser plugin.
56
Group: Multimedia
57
Requires: lightspark-common
58
59
%description browser-plugin
60
Lightspark is a free Flash player for Linux which aims for high-performance
61
by using modern technologies such as JIT compilation and OpenGL shaders.
62
63
The project is currently in an alpha status and provides the standalone
64
player and browser plugin for testing purposes only.
65
66
Nice features:
67
* JIT compilation of ActionScript to native x86 bytecode
68
* Hardware accelerated rendering using OpenGL shaders (GLSL)
69
* Aims to support current-generation ActionScript 3
70
* A new, clean, codebase exploiting multithreading and optimized for modern
71
hardware. Designed from scratch after the official Flash documentation was
72
released.
73
74
%package common
75
Summary: This package contains the common library and data.
76
Group: Multimedia
77
78
%description common
79
Lightspark is an LGPL-3.0+ licensed Flash player and browser
80
plugin written in C++/C that runs on Linux. It aims to support
81
Adobe's newer Flash formats and AVM2 virtual machine.
82
83
%prep
84
%setup -q
85
86
%build
87
export CFLAGS='%{optflags}'
88
export CXXFLAGS='%{optflags}'
89
mkdir build
90
cd build
91
cmake -DCMAKE_BUILD_WITH_INSTALL_RPATH=1 \
92
-DCMAKE_VERBOSE_MAKEFILE=1 \
93
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
94
-DLIB_SUFFIX=$(echo %{_lib} | cut -b4-) \
95
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
96
-DPLUGIN_DIRECTORY=%{_libdir}/browser-plugins \
97
-DCMAKE_BUILD_TYPE=Release \
98
-DENABLE_LIBAVCODEC=1 ..
99
make %{?_smp_mflags}
100
%install
101
cd build
102
%make_install
103
cd ..
104
105
# Remove non-standard icon directory
106
pushd %{buildroot}%{_datadir}/icons/hicolor
107
rm -rf 20x20
108
popd
109
%suse_update_desktop_file %{buildroot}%{_datadir}/applications/%{name}.desktop
110
%find_lang %{name}
111
rm -f %{buildroot}%{_libdir}/%{name}/lib%{name}.so
112
# Not in hicolor theme (lp#1000840)
113
rm -rf %{buildroot}%{_datadir}/icons/hicolor/20x20
114
pushd $RPM_BUILD_ROOT%{_datadir}/man/man1
115
ln -s %{name}.1.gz tightspark.1.gz
116
popd
117
118
%clean
119
%{?buildroot:rm -rf %{buildroot}}
120
121
%files browser-plugin
122
%{_libdir}/browser-plugins/lib%{name}plugin.so
123
%dir /%{_prefix}/lib/%{name}/plugins/
124
%{_prefix}/lib/%{name}/plugins/lib%{name}pulseplugin.so
125
126
%files
127
%{_bindir}/lightspark
128
%{_bindir}/tightspark
129
%{_datadir}/applications/%{name}.desktop
130
%{_datadir}/icons/hicolor/*/*/
131
132
%files common
133
%defattr(-,root,root)
134
%config (noreplace) %{_sysconfdir}/xdg/%{name}.conf
135
%{_prefix}/lib/%{name}/lib%{name}.so.0.6.0
136
%{_prefix}/lib/%{name}/lib%{name}.so.0.6
137
%{_datadir}/%{name}/
138
%{_mandir}/man1/%{name}.1.gz
139
%{_mandir}/man1/tightspark.1.gz
140
141
%files lang -f %{name}.lang
142
%defattr(-,root,root,-)
143
144
%changelog
145