Projects
Essentials
libx264
libx264.spec
Sign Up
Log In
Username
Password
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File libx264.spec of Package libx264 (Revision 20)
Currently displaying revision
20
,
Show latest
# # spec file for package libx264 # # Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # %define soname 152 %define svn 20180305 %bcond_without gpac %bcond_with x264_binary Name: libx264 Version: 0.%{soname}svn%{svn} Release: 0 Summary: A free h264/avc encoder - encoder binary License: GPL-2.0+ Group: Productivity/Multimedia/Video/Editors and Convertors Url: http://www.videolan.org/developers/x264.html Source: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{svn}-2245-stable.tar.bz2 Source1: baselibs.conf Patch0: x264-use-shared-library.patch %if 0%{?suse_version} >= 1500 BuildRequires: nasm >= 2.13 %endif BuildRequires: pkgconfig BuildRequires: yasm >= 1.2.0 BuildRoot: %{_tmppath}/%{name}-%{version}-build %if %{with x264_binary} %if %{with gpac} BuildRequires: libgpac-devel %endif BuildRequires: pkgconfig(ffms2) BuildRequires: pkgconfig(libavcodec) BuildRequires: pkgconfig(libavformat) BuildRequires: pkgconfig(libavutil) BuildRequires: pkgconfig(libswscale) %endif %description x264 is a free library for encoding next-generation H264/AVC video streams. The code is written from scratch by Laurent Aimar, Loren Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and Alex Wright. It is released under the terms of the GPL license. This package contains a shared library and a commandline tool for encoding H264 streams. This library is needed for mplayer/mencoder for H264 encoding support. Encoder features: - CAVLC/CABAC - Multi-references - Intra: all macroblock types (16x16, 8x8, and 4x4 with all predictions) - Inter P: all partitions (from 16x16 down to 4x4) - Inter B: partitions from 16x16 down to 8x8 (including skip/direct) - Ratecontrol: constant quantizer, single or multipass ABR, optional VBV - Scene cut detection - Adaptive B-frame placement - B-frames as references / arbitrary frame order - 8x8 and 4x4 adaptive spatial transform - Lossless mode - Custom quantization matrices - Parallel encoding of multiple slices (currently disabled) %package %{soname} Summary: A free h264/avc encoder - encoder binary Group: System/Libraries %description %{soname} x264 is a free library for encoding next-generation H264/AVC video streams. The code is written from scratch by Laurent Aimar, Loren Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and Alex Wright. It is released under the terms of the GPL license. This package contains a static library and a header needed for the development with libx264. This library is needed to build mplayer/mencoder with H264 encoding support. %package -n x264 Summary: Binaries for x264 streams conversions %description -n x264 x264 is a free library for encoding next-generation H264/AVC video streams. The code is written from scratch by Laurent Aimar, Loren Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and Alex Wright. It is released under the terms of the GPL license. This package contains a static library and a header needed for the development with libx264. This library is needed to build mplayer/mencoder with H264 encoding support. %package devel Summary: Libraries and include file for the %{name} encoder Group: Development/Libraries/C and C++ Requires: %{name}-%{soname} = %{version} Provides: x264-devel = %{version} Obsoletes: x264-devel < %{version} %description devel x264 is a free library for encoding next-generation H264/AVC video streams. The code is written from scratch by Laurent Aimar, Loren Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and Alex Wright. It is released under the terms of the GPL license. This package contains a static library and a header needed for the development with libx264. This library is needed to build mplayer/mencoder with H264 encoding support. %prep %setup -q -n x264-snapshot-%{svn}-2245-stable %patch0 -p1 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e %%Y') sed -i "s/__DATE__/\"$FAKE_BUILDDATE\"/" x264.c %build %configure \ --disable-lsmash \ --disable-opencl \ %if 0%{?suse_version} < 1500 --disable-asm \ %endif --enable-shared \ %if %{with x264_binary} --enable-swscale \ --enable-lavf \ --enable-ffms \ %if %{with gpac} --enable-gpac \ %else --disable-gpac \ %endif %else --disable-cli \ --disable-swscale \ --disable-lavf \ --disable-ffms \ --disable-gpac \ %endif --enable-pic make %{?_smp_mflags} %install %if %{with x264_binary} install -Dm 755 x264 %{buildroot}/%{_bindir}/x264 %else make %{?_smp_mflags} DESTDIR=%{buildroot} install rm -f %{buildroot}%{_libdir}/%{name}.so rm -f %{buildroot}%{_libdir}/%{name}.a ln -s %{name}.so.%{soname} %{buildroot}%{_libdir}/%{name}.so %endif %if %{with x264_binary} %files -n x264 %defattr(-,root,root) %doc doc/*.txt %attr(0755,root,root) %{_bindir}/x264 %else %post -n %{name}-%{soname} -p /sbin/ldconfig %postun -n %{name}-%{soname} -p /sbin/ldconfig %files %{soname} %defattr(0644,root,root) %{_libdir}/%{name}.so.%{soname} %files devel %defattr(0644,root,root) %{_includedir}/x264.h %{_includedir}/x264_config.h %{_libdir}/pkgconfig/x264.pc %{_libdir}/%{name}.so %endif %changelog
Locations
Projects
Search
Status Monitor
Help
Open Build Service
OBS Manuals
API Documentation
OBS Portal
Reporting a Bug
Contact
Mailing List
Forums
Chat (IRC)
Twitter
Open Build Service (OBS)
is an
openSUSE project
.