File ffmpeg-3.spec of Package A_tw-ffmpeg-3 (Revision 4)
Currently displaying revision 4 , Show latest
698
1
#
2
# spec file for package ffmpeg-3
3
#
4
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
%define _lto_cflags %{nil}
20
# Create proper conflicts to make sure we require all from one version
21
# p: Conflict string, eg if you need them all for requires instead
22
# Default value Conflicts:
23
# c: copmare string ie "<" or ">=", must be defined
24
# v: version string ie. "< 42.3.4" or ">= 15.0.2.1", must be defined
25
%define devel_conflicts(p:c:v:) \
26
%define preamble_string %{-p:%{-p*}}%{!-p:Conflicts:} \
27
%define comparator %{-c:%{-c*}}%{!-c:%{error:Comparator not defined}} \
28
%define conflicts_version %{-v:%{-v*}}%{!-v:%{error:Version not defined}} \
29
\
30
%{preamble_string} libavcodec-devel %{comparator} %{conflicts_version} \
31
%{preamble_string} libavdevice-devel %{comparator} %{conflicts_version} \
32
%{preamble_string} libavfilter-devel %{comparator} %{conflicts_version} \
33
%{preamble_string} libavformat-devel %{comparator} %{conflicts_version} \
34
%{preamble_string} libavresample-devel %{comparator} %{conflicts_version} \
35
%{preamble_string} libavutil-devel %{comparator} %{conflicts_version} \
36
%{preamble_string} libpostproc-devel %{comparator} %{conflicts_version} \
37
%{preamble_string} libswresample-devel %{comparator} %{conflicts_version} \
38
%{preamble_string} libswscale-devel %{comparator} %{conflicts_version} \
39
%{preamble_string} ffmpeg-private-devel %{comparator} %{conflicts_version} \
40
%{nil}
41
42
%bcond_with fdk_aac
43
%bcond_without librtmp
44
%bcond_without nvidia
45
%bcond_without opencore
46
%bcond_without vidstab
47
%bcond_without vo_aacenc
48
%bcond_without x264
49
%bcond_without x265
50
%bcond_without xvid
51
%bcond_without zimg
52
%bcond_without ffmpeg3_full_build
53
54
55
%define _major_version 3
56
%define _major_expected 4
57
Name: ffmpeg-3
58
Version: 3.4.13
59
Release: 0
60
Summary: Library for working with various multimedia formats
61
License: LGPL-2.1-or-later AND GPL-2.0-or-later
62
Group: Productivity/Multimedia/Video/Editors and Convertors
63
Url: https://git.ffmpeg.org/gitweb/ffmpeg.git
64
Source: %name-%version.tar.xz
65
Source3: %name-rpmlintrc
66
Source4: enable_decoders
67
Source5: enable_encoders
68
Source99: baselibs.conf
69
Patch0: %name.patch
70
Patch1: ffmpeg-libcdio_cdda-pkgconfig.patch
71
Patch2: ffmpeg-arm6l.diff
72
Patch3: ffmpeg-libopenjpeg.patch
73
Patch4: ffmpeg-codec-choice.diff
74
Patch6: 0001-opusenc-psy-disable-stereo-searches.patch
75
Patch7: ffmpeg-fix-build-fdk-aac2.patch
76
Patch8: ffmpeg-x86-mathops.patch
77
BuildRequires: ladspa-devel
78
BuildRequires: libgsm-devel
79
BuildRequires: libmp3lame-devel
80
BuildRequires: nasm
81
BuildRequires: pkg-config
82
BuildRequires: pkgconfig(alsa)
83
BuildRequires: pkgconfig(bzip2)
84
BuildRequires: pkgconfig(celt) >= 0.11.0
85
BuildRequires: pkgconfig(enca)
86
BuildRequires: pkgconfig(fontconfig) >= 2.4.2
87
BuildRequires: pkgconfig(freetype2)
88
BuildRequires: pkgconfig(fribidi) >= 0.19.0
89
BuildRequires: pkgconfig(gnutls)
90
BuildRequires: pkgconfig(jack)
91
BuildRequires: pkgconfig(libass)
92
BuildRequires: pkgconfig(libbluray)
93
BuildRequires: pkgconfig(libcdio)
94
BuildRequires: pkgconfig(libcdio_paranoia)
95
BuildRequires: pkgconfig(libdc1394-2)
96
BuildRequires: pkgconfig(liboil-0.3) >= 0.3.15
97
BuildRequires: pkgconfig(libpulse)
98
BuildRequires: pkgconfig(libraw1394)
99
BuildRequires: pkgconfig(libva) >= 0.35.0
100
BuildRequires: pkgconfig(libwebp) >= 0.4
101
BuildRequires: pkgconfig(ogg)
102
BuildRequires: pkgconfig(opus)
103
BuildRequires: pkgconfig(speex)
104
BuildRequires: pkgconfig(theora) >= 1.1
105
BuildRequires: pkgconfig(twolame)
106
BuildRequires: pkgconfig(vdpau)
107
%if %{with vidstab}
108
BuildRequires: pkgconfig(vidstab) >= 0.98
109
%endif
110
BuildRequires: pkgconfig(vorbis)
111
BuildRequires: pkgconfig(vpx) >= 1.3.0
112
BuildRequires: pkgconfig(x11)
113
BuildRequires: pkgconfig(xcb)
114
BuildRequires: pkgconfig(xcb-render)
115
BuildRequires: pkgconfig(xcb-shape)
116
BuildRequires: pkgconfig(xcb-shm)
117
BuildRequires: pkgconfig(xcb-xfixes)
118
BuildRequires: pkgconfig(xext)
119
BuildRequires: pkgconfig(xfixes)
120
%if %{with zimg}
121
BuildRequires: pkgconfig(zimg)
122
%endif
123
BuildRequires: pkgconfig(zlib)
124
BuildRequires: pkgconfig(zvbi-0.2)
125
BuildRequires: pkgconfig(libopenjp2)
126
BuildRequires: pkgconfig(sdl2)
127
%if %{with fdk_aac}
128
BuildRequires: pkgconfig(fdk-aac)
129
%endif
130
%if %{with librtmp}
131
BuildRequires: pkgconfig(librtmp)
132
%endif
133
%if %{with xvid}
134
BuildRequires: libxvidcore-devel
135
%endif
136
%if %{with opencore}
137
BuildRequires: pkgconfig(opencore-amrnb)
138
%endif
139
%if %{with x264}
140
BuildRequires: pkgconfig(x264)
141
%endif
142
%if %{with x265}
143
BuildRequires: pkgconfig(x265)
144
%endif
145
Provides: ffmpeg-tools = %version-%release
146
Obsoletes: ffmpeg-tools < %version-%release
147
Provides: ffmpeg = %version-%release
148
Obsoletes: ffmpeg < %version-%release
149
Requires: libavcodec57 = %version-%release
150
Requires: libavdevice57 = %version-%release
151
Requires: libavfilter6 = %version-%release
152
Requires: libavformat57 = %version-%release
153
Requires: libavresample3 = %version-%release
154
Requires: libavutil55 = %version-%release
155
Requires: libpostproc54 = %version-%release
156
Requires: libswresample2 = %version-%release
157
Requires: libswscale4 = %version-%release
158
159
%description
160
FFmpeg is a multimedia framework, able to decode, encode,
161
transcode, mux, demux, stream, filter and play several formats
162
that humans and machines have created.
163
164
%package -n libavcodec57
165
Summary: FFmpeg codec library
166
# For mozillas
167
Group: System/Libraries
168
Requires: libavutil55 = %version-%release
169
Requires: libswresample2 = %version-%release
170
Provides: libavcodec = %version-%release
171
Provides: libavcodec-full = %version-%release
172
# This can be required by packages likes vlc-codecs - following the shlib name to not get random lib providers
173
Provides: libavcodec57(unrestricted)
174
175
%description -n libavcodec57
176
The libavcodec library provides a generic encoding/decoding framework
177
and contains multiple decoders and encoders for audio, video and
178
subtitle streams, and several bitstream filters.
179
180
%package libavcodec-devel
181
Summary: Development files for FFmpeg's codec library
182
Group: Development/Libraries/C and C++
183
Provides: libavcodec-devel = %version-%release
184
Obsoletes: libavcodec-devel < %version-%release
185
Requires: %{name}-libavresample-devel = %version-%release
186
Requires: %{name}-libavutil-devel = %version-%release
187
Requires: libavcodec57 = %version-%release
188
%devel_conflicts -c < -v %{_major_version}
189
%devel_conflicts -c >= -v %{_major_expected}
190
191
%description libavcodec-devel
192
The libavcodec library provides a generic encoding/decoding framework
193
and contains multiple decoders and encoders for audio, video and
194
subtitle streams, and several bitstream filters.
195
196
This subpackage contains the headers for FFmpeg libavcodec.
197
198
%package -n libavdevice57
199
Summary: FFmpeg device library
200
Group: System/Libraries
201
Requires: libavcodec57 = %version-%release
202
Requires: libavfilter6 = %version-%release
203
Requires: libavformat57 = %version-%release
204
Requires: libavutil55 = %version-%release
205
206
%description -n libavdevice57
207
The libavdevice library provides a generic framework for grabbing from
208
and rendering to many common multimedia input/output devices, and
209
supports several input and output devices, including Video4Linux2, VfW,
210
DShow, and ALSA.
211
212
%package libavdevice-devel
213
Summary: Development files for FFmpeg's device library
214
Group: Development/Libraries/C and C++
215
Provides: ffmpeg-devel = %version-%release
216
Conflicts: ffmpeg-devel
217
Provides: ffmpeg3-devel = %version-%release
218
Obsoletes: ffmpeg3-devel < %version-%release
219
Provides: libavdevice-devel = %version-%release
220
Obsoletes: libavdevice-devel < %version-%release
221
Requires: %{name}-libavcodec-devel = %version-%release
222
Requires: %{name}-libavfilter-devel = %version-%release
223
Requires: %{name}-libavformat-devel = %version-%release
224
Requires: %{name}-libavresample-devel = %version-%release
225
Requires: %{name}-libavutil-devel = %version-%release
226
Requires: %{name}-libpostproc-devel = %version-%release
227
Requires: %{name}-libswresample-devel = %version-%release
228
Requires: %{name}-libswscale-devel = %version-%release
229
Requires: libavdevice57 = %version-%release
230
%devel_conflicts -c < -v %{_major_version}
231
%devel_conflicts -c >= -v %{_major_expected}
232
233
%description libavdevice-devel
234
The libavdevice library provides a generic framework for grabbing from
235
and rendering to many common multimedia input/output devices, and
236
supports several input and output devices, including Video4Linux2, VfW,
237
DShow, and ALSA.
238
239
This subpackage contains the headers for FFmpeg libavcodec.
240
241
%package -n libavfilter6
242
Summary: FFmpeg audio and video filtering library
243
Group: System/Libraries
244
Requires: libavcodec57 = %version-%release
245
Requires: libavformat57 = %version-%release
246
Requires: libavresample3 = %version-%release
247
Requires: libavutil55 = %version-%release
248
Requires: libpostproc54 = %version-%release
249
Requires: libswresample2 = %version-%release
250
Requires: libswscale4 = %version-%release
251
252
%description -n libavfilter6
253
The libavfilter library provides a generic audio/video filtering
254
framework containing several filters, sources and sinks.
255
256
%package libavfilter-devel
257
Summary: Development files for FFmpeg's audio/video filter library
258
Group: Development/Libraries/C and C++
259
Provides: libavfilter-devel = %version-%release
260
Obsoletes: libavfilter-devel < %version-%release
261
Requires: %{name}-libavcodec-devel = %version-%release
262
Requires: %{name}-libavformat-devel = %version-%release
263
Requires: %{name}-libavresample-devel = %version-%release
264
Requires: %{name}-libavutil-devel = %version-%release
265
Requires: %{name}-libpostproc-devel = %version-%release
266
Requires: %{name}-libswresample-devel = %version-%release
267
Requires: %{name}-libswscale-devel = %version-%release
268
Requires: libavfilter6 = %version-%release
269
%devel_conflicts -c < -v %{_major_version}
270
%devel_conflicts -c >= -v %{_major_expected}
271
272
%description libavfilter-devel
273
The libavfilter library provides a generic audio/video filtering
274
framework containing several filters, sources and sinks.
275
276
This subpackage contains the headers for FFmpeg libavfilter.
277
278
%package -n libavformat57
279
Summary: FFmpeg's stream format library
280
Group: System/Libraries
281
Requires: libavcodec57 = %version-%release
282
Requires: libavutil55 = %version-%release
283
284
%description -n libavformat57
285
The libavformat library provides a generic framework for multiplexing
286
and demultiplexing (muxing and demuxing) audio, video and subtitle
287
streams. It encompasses multiple muxers and demuxers for multimedia
288
container formats.
289
290
%package libavformat-devel
291
Summary: Development files for FFmpeg's stream format library
292
Group: Development/Libraries/C and C++
293
Provides: libavformat-devel = %version-%release
294
Obsoletes: libavformat-devel < %version-%release
295
Requires: %{name}-libavcodec-devel = %version-%release
296
Requires: %{name}-libavutil-devel = %version-%release
297
Requires: %{name}-libswresample-devel = %version-%release
298
Requires: libavformat57 = %version-%release
299
%devel_conflicts -c < -v %{_major_version}
300
%devel_conflicts -c >= -v %{_major_expected}
301
302
%description libavformat-devel
303
The libavformat library provides a generic framework for multiplexing
304
and demultiplexing (muxing and demuxing) audio, video and subtitle
305
streams. It encompasses multiple muxers and demuxers for multimedia
306
container formats.
307
308
This subpackage contains the headers for FFmpeg libavformat.
309
310
%package -n libavresample3
311
Summary: FFmpeg alternate audio resampling library
312
Group: System/Libraries
313
Requires: libavutil55 = %version-%release
314
315
%description -n libavresample3
316
An audio resampling library that is being provided for drop-in
317
compatibility with libav.
318
319
It is advised to use libswresample for new code.
320
321
%package libavresample-devel
322
Summary: Development files for libavresample as present in FFmpeg
323
Group: Development/Libraries/C and C++
324
Provides: libavresample-devel = %version-%release
325
Obsoletes: libavresample-devel < %version-%release
326
Requires: %{name}-libavutil-devel = %version-%release
327
Requires: libavresample3 = %version-%release
328
%devel_conflicts -c < -v %{_major_version}
329
%devel_conflicts -c >= -v %{_major_expected}
330
331
%description libavresample-devel
332
An audio resampling library that is being provided for drop-in
333
compatibility with libav.
334
335
It is advised to use libswresample for new code.
336
337
This subpackage contains the headers for FFmpeg's copy of libavresample.
338
339
%package -n libavutil55
340
Summary: FFmpeg's utility library
341
Group: System/Libraries
342
343
%description -n libavutil55
344
The libavutil library is a utility library to aid portable multimedia
345
programming. It contains safe portable string functions, random
346
number generators, data structures, additional mathematics functions,
347
cryptography and multimedia related functionality (like enumerations
348
for pixel and sample formats).
349
350
%package libavutil-devel
351
Summary: Development files for FFmpeg's utility library
352
Group: Development/Libraries/C and C++
353
Provides: libavutil-devel = %version-%release
354
Obsoletes: libavutil-devel < %version-%release
355
Requires: libavutil55 = %version-%release
356
%devel_conflicts -c < -v %{_major_version}
357
%devel_conflicts -c >= -v %{_major_expected}
358
359
%description libavutil-devel
360
The libavutil library is a utility library to aid portable multimedia
361
programming. It contains safe portable string functions, random
362
number generators, data structures, additional mathematics functions,
363
cryptography and multimedia related functionality (like enumerations
364
for pixel and sample formats).
365
366
This subpackage contains the headers for FFmpeg libavutil.
367
368
%package -n libpostproc54
369
Summary: FFmpeg post-processing library
370
Group: System/Libraries
371
Requires: libavutil55 = %version-%release
372
373
%description -n libpostproc54
374
A library with video postprocessing filters, such as deblocking and
375
deringing filters, noise reduction, automatic contrast and brightness
376
correction, linear/cubic interpolating deinterlacing.
377
378
%package libpostproc-devel
379
Summary: Development files for the FFmpeg post-processing library
380
Group: Development/Libraries/C and C++
381
Provides: libpostproc-devel = %version-%release
382
Obsoletes: libpostproc-devel < %version-%release
383
Requires: %{name}-libavutil-devel = %version-%release
384
Requires: libpostproc54 = %version-%release
385
%devel_conflicts -c < -v %{_major_version}
386
%devel_conflicts -c >= -v %{_major_expected}
387
388
%description libpostproc-devel
389
A library with video postprocessing filters, such as deblocking and
390
deringing filters, noise reduction, automatic contrast and brightness
391
correction, linear/cubic interpolating deinterlacing.
392
393
This subpackage contains the headers for FFmpeg libpostproc.
394
395
%package -n libswresample2
396
Summary: FFmpeg software resampling library
397
Group: System/Libraries
398
Requires: libavutil55 = %version-%release
399
400
%description -n libswresample2
401
The libswresample library performs audio conversion between different
402
sample rates, channel layout and channel formats.
403
404
%package libswresample-devel
405
Summary: Development files for the FFmpeg software resampling library
406
Group: Development/Libraries/C and C++
407
Provides: libswresample-devel = %version-%release
408
Obsoletes: libswresample-devel < %version-%release
409
Requires: %{name}-libavutil-devel = %version-%release
410
Requires: libswresample2 = %version-%release
411
%devel_conflicts -c < -v %{_major_version}
412
%devel_conflicts -c >= -v %{_major_expected}
413
414
%description libswresample-devel
415
The libswresample library performs audio conversion between different
416
sample rates, channel layout and channel formats.
417
418
This subpackage contains the headers for FFmpeg libswresample.
419
420
%package -n libswscale4
421
Summary: FFmpeg image scaling and colorspace/pixel conversion library
422
Group: System/Libraries
423
Requires: libavutil55 = %version-%release
424
425
%description -n libswscale4
426
The libswscale library performs image scaling and colorspace and
427
pixel format conversion operations.
428
429
%package libswscale-devel
430
Summary: Development files for FFmpeg's image scaling and colorspace library
431
Group: Development/Libraries/C and C++
432
Provides: libswscale-devel = %version-%release
433
Conflicts: libswscale-devel
434
Requires: %{name}-libavutil-devel = %version-%release
435
Requires: libswscale4 = %version-%release
436
%devel_conflicts -c < -v %{_major_version}
437
%devel_conflicts -c >= -v %{_major_expected}
438
439
%description libswscale-devel
440
The libswscale library performs image scaling and colorspace and
441
pixel format conversion operations.
442
443
This subpackage contains the headers for FFmpeg libswscale.
444
445
%package private-devel
446
Summary: Some FFmpeg private headers
447
Group: Development/Libraries/C and C++
448
Requires: %{name}-libavcodec-devel = %version-%release
449
Requires: %{name}-libavformat-devel = %version-%release
450
Requires: %{name}-libavutil-devel = %version-%release
451
Provides: ffmpeg-private-devel = %version
452
Obsoletes: ffmpeg-private-devel < %version
453
%devel_conflicts -c < -v %{_major_version}
454
%devel_conflicts -c >= -v %{_major_expected}
455
456
%description private-devel
457
FFmpeg is a multimedia framework, able to decode, encode,
458
transcode, mux, demux, stream, filter and play several formats
459
that humans and machines have created.
460
461
This package contains some private headers for libavformat, libavcodec and
462
libavutil which are needed by libav-tools to build. No other package apart
463
from libav should depend on these private headers which are expected to
464
break compatibility without any notice.
465
466
%prep
467
%autosetup -p1
468
469
%build
470
echo '%version' > VERSION
471
perl -i -pe 's{__TIME__|__DATE__}{"$&"}g' *.c
472
473
if \
474
env \
475
CFLAGS="%optflags" \
476
./configure \
477
--prefix="%_prefix" --libdir="%_libdir" --shlibdir="%_libdir" \
478
--incdir="%_includedir/ffmpeg" \
479
--extra-cflags="%optflags" --optflags="%optflags" \
480
--disable-htmlpages \
481
--enable-pic --disable-stripping \
482
--enable-shared --disable-static \
483
--enable-gpl \
484
--disable-openssl \
485
--enable-avresample \
486
--enable-libcdio \
487
--enable-gnutls \
488
--enable-ladspa \
489
%if %{without nvidia}
490
--disable-cuda \
491
--disable-cuvid \
492
%endif
493
--enable-libass \
494
--enable-libbluray \
495
--enable-libcelt \
496
--enable-libcdio \
497
--enable-libdc1394 \
498
--enable-libfreetype \
499
--enable-libgsm \
500
--enable-libmp3lame \
501
--enable-libopenjpeg \
502
--enable-libopus \
503
--enable-libpulse \
504
--enable-libspeex \
505
--enable-libtheora \
506
--enable-libtwolame \
507
%if %{with vidstab}
508
--enable-libvidstab \
509
%endif
510
--enable-libvorbis \
511
--enable-libvpx \
512
--enable-libwebp \
513
%if %{with zimg}
514
--enable-libzimg \
515
%endif
516
--enable-libzvbi \
517
--enable-vaapi \
518
--enable-vdpau \
519
%if %{with fdk_aac}
520
--enable-libfdk_aac --enable-nonfree \
521
%endif
522
%if %{with opencore}
523
--enable-libopencore-amrnb \
524
--enable-libopencore-amrwb \
525
--enable-version3 \
526
%endif
527
%if %{with x264}
528
--enable-libx264 \
529
%endif
530
%if %{with x265}
531
--enable-libx265 \
532
%endif
533
%if %{with xvid}
534
--enable-libxvid \
535
%endif
536
%{nil}
537
then
538
: good
539
else
540
: bad
541
cat ffbuild/config.log
542
exit 1
543
fi
544
545
cat config.h
546
%make_build
547
548
%global extratools aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper probetest qt-faststart seek_print sidxindex trasher
549
550
for i in %extratools; do
551
make "tools/$i"
552
done
553
554
%install
555
b="%buildroot"
556
%make_install install-man
557
558
%if %{with ffmpeg3_full_build}
559
rm -Rf "$b/%_datadir/ffmpeg/examples"
560
for i in %extratools; do
561
cp -a "tools/$i" "$b/%_bindir/"
562
done
563
%else
564
rm -Rf "$b/%_bindir" "$b/%_mandir/man1" "$b/%_datadir/ffmpeg"
565
%endif
566
567
# Install private headers required by libav-tools
568
for i in libavformat/options_table.h libavformat/os_support.h \
569
libavformat/internal.h libavcodec/options_table.h libavutil/libm.h \
570
libavutil/internal.h libavutil/colorspace.h libavutil/timer.h \
571
libavutil/x86/emms.h libavutil/aarch64/timer.h libavutil/arm/timer.h \
572
libavutil/bfin/timer.h libavutil/ppc/timer.h libavutil/x86/timer.h; do
573
mkdir -p "$b/%_includedir/ffmpeg/private/"`dirname $i`
574
cp -a $i "$b/%_includedir/ffmpeg/private/$i"
575
done
576
577
%post -n libavcodec57 -p /sbin/ldconfig
578
%postun -n libavcodec57 -p /sbin/ldconfig
579
%post -n libavdevice57 -p /sbin/ldconfig
580
%postun -n libavdevice57 -p /sbin/ldconfig
581
%post -n libavfilter6 -p /sbin/ldconfig
582
%postun -n libavfilter6 -p /sbin/ldconfig
583
%post -n libavformat57 -p /sbin/ldconfig
584
%postun -n libavformat57 -p /sbin/ldconfig
585
%post -n libavresample3 -p /sbin/ldconfig
586
%postun -n libavresample3 -p /sbin/ldconfig
587
%post -n libavutil55 -p /sbin/ldconfig
588
%postun -n libavutil55 -p /sbin/ldconfig
589
%post -n libpostproc54 -p /sbin/ldconfig
590
%postun -n libpostproc54 -p /sbin/ldconfig
591
%post -n libswresample2 -p /sbin/ldconfig
592
%postun -n libswresample2 -p /sbin/ldconfig
593
%post -n libswscale4 -p /sbin/ldconfig
594
%postun -n libswscale4 -p /sbin/ldconfig
595
596
%if %{with ffmpeg3_full_build}
597
%files
598
%doc CREDITS README.md
599
%_bindir/*
600
%_mandir/man1/ff*.1*
601
%_datadir/ffmpeg/
602
%endif
603
604
%files -n libavcodec57
605
%_libdir/libavcodec.so.*
606
607
%files -n libavdevice57
608
%_libdir/libavdevice.so.*
609
610
%files -n libavfilter6
611
%_libdir/libavfilter.so.*
612
613
%files -n libavformat57
614
%_libdir/libavformat.so.*
615
616
%files -n libavresample3
617
%_libdir/libavresample.so.*
618
619
%files -n libavutil55
620
%doc Changelog
621
%license COPYING.GPLv2 LICENSE.md
622
%_libdir/libavutil.so.*
623
624
%files -n libpostproc54
625
%_libdir/libpostproc.so.*
626
627
%files -n libswresample2
628
%_libdir/libswresample.so.*
629
630
%files -n libswscale4
631
%_libdir/libswscale.so.*
632
633
%files libavcodec-devel
634
%dir %_includedir/ffmpeg/
635
%_includedir/ffmpeg/libavcodec/
636
%_libdir/libavcodec.so
637
%_libdir/pkgconfig/libavcodec.pc
638
%_mandir/man3/libavcodec.3*
639
640
%files libavdevice-devel
641
%dir %_includedir/ffmpeg/
642
%_includedir/ffmpeg/libavdevice/
643
%_libdir/libavdevice.so
644
%_libdir/pkgconfig/libavdevice.pc
645
%_mandir/man3/libavdevice.3*
646
647
%files libavfilter-devel
648
%dir %_includedir/ffmpeg/
649
%_includedir/ffmpeg/libavfilter/
650
%_libdir/libavfilter.so
651
%_libdir/pkgconfig/libavfilter.pc
652
%_mandir/man3/libavfilter.3*
653
654
%files libavformat-devel
655
%dir %_includedir/ffmpeg/
656
%_includedir/ffmpeg/libavformat/
657
%_libdir/libavformat.so
658
%_libdir/pkgconfig/libavformat.pc
659
%_mandir/man3/libavformat.3*
660
661
%files libavresample-devel
662
%dir %_includedir/ffmpeg/
663
%_includedir/ffmpeg/libavresample/
664
%_libdir/libavresample.so
665
%_libdir/pkgconfig/libavresample.pc
666
667
%files libavutil-devel
668
%dir %_includedir/ffmpeg/
669
%_includedir/ffmpeg/libavutil/
670
%_libdir/libavutil.so
671
%_libdir/pkgconfig/libavutil.pc
672
%_mandir/man3/libavutil.3*
673
674
%files libpostproc-devel
675
%dir %_includedir/ffmpeg/
676
%_includedir/ffmpeg/libpostproc/
677
%_libdir/libpostproc.so
678
%_libdir/pkgconfig/libpostproc.pc
679
680
%files libswresample-devel
681
%dir %_includedir/ffmpeg/
682
%_includedir/ffmpeg/libswresample/
683
%_libdir/libswresample.so
684
%_libdir/pkgconfig/libswresample.pc
685
%_mandir/man3/libswresample.3*
686
687
%files libswscale-devel
688
%dir %_includedir/ffmpeg/
689
%_includedir/ffmpeg/libswscale/
690
%_libdir/libswscale.so
691
%_libdir/pkgconfig/libswscale.pc
692
%_mandir/man3/libswscale.3*
693
694
%files private-devel
695
%_includedir/ffmpeg/private/
696
697
%changelog
698