File ffmpeg-3.spec of Package A_tw-ffmpeg-3 (Revision 2985d3ab77a773b64e703094e1da4b38)

Currently displaying revision 2985d3ab77a773b64e703094e1da4b38 , Show latest

696
 
1
#
2
# spec file for package ffmpeg-3
3
#
4
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
%define _lto_cflags %{nil}
20
# Create proper conflicts to make sure we require all from one version
21
# p:   Conflict string, eg if you need them all for requires instead
22
#      Default value Conflicts:
23
# c:   copmare string ie "<" or ">=", must be defined
24
# v:   version string ie. "< 42.3.4" or ">= 15.0.2.1", must be defined
25
%define devel_conflicts(p:c:v:) \
26
%define preamble_string %{-p:%{-p*}}%{!-p:Conflicts:} \
27
%define comparator %{-c:%{-c*}}%{!-c:%{error:Comparator not defined}} \
28
%define conflicts_version %{-v:%{-v*}}%{!-v:%{error:Version not defined}} \
29
\
30
%{preamble_string} libavcodec-devel %{comparator} %{conflicts_version} \
31
%{preamble_string} libavdevice-devel %{comparator} %{conflicts_version} \
32
%{preamble_string} libavfilter-devel %{comparator} %{conflicts_version} \
33
%{preamble_string} libavformat-devel %{comparator} %{conflicts_version} \
34
%{preamble_string} libavresample-devel %{comparator} %{conflicts_version} \
35
%{preamble_string} libavutil-devel %{comparator} %{conflicts_version} \
36
%{preamble_string} libpostproc-devel %{comparator} %{conflicts_version} \
37
%{preamble_string} libswresample-devel %{comparator} %{conflicts_version} \
38
%{preamble_string} libswscale-devel %{comparator} %{conflicts_version} \
39
%{preamble_string} ffmpeg-private-devel %{comparator} %{conflicts_version} \
40
%{nil}
41
42
%bcond_with    fdk_aac
43
%bcond_without librtmp
44
%bcond_without nvidia
45
%bcond_without opencore
46
%bcond_without vidstab
47
%bcond_without vo_aacenc
48
%bcond_without x264
49
%bcond_without x265
50
%bcond_without xvid
51
%bcond_without zimg
52
%bcond_without ffmpeg3_full_build
53
54
55
%define _major_version 3
56
%define _major_expected 4
57
Name:           ffmpeg-3
58
Version:        3.4.12
59
Release:        0
60
Summary:        Library for working with various multimedia formats
61
License:        LGPL-2.1-or-later AND GPL-2.0-or-later
62
Group:          Productivity/Multimedia/Video/Editors and Convertors
63
Url:            https://git.ffmpeg.org/gitweb/ffmpeg.git
64
Source:         %name-%version.tar.xz
65
Source3:        %name-rpmlintrc
66
Source4:        enable_decoders
67
Source5:        enable_encoders
68
Source99:       baselibs.conf
69
Patch1:         ffmpeg-libcdio_cdda-pkgconfig.patch
70
Patch2:         ffmpeg-arm6l.diff
71
Patch3:         ffmpeg-libopenjpeg.patch
72
Patch4:         ffmpeg-codec-choice.diff
73
Patch6:         0001-opusenc-psy-disable-stereo-searches.patch
74
Patch7:         ffmpeg-fix-build-fdk-aac2.patch
75
BuildRequires:  ladspa-devel
76
BuildRequires:  libgsm-devel
77
BuildRequires:  libmp3lame-devel
78
BuildRequires:  nasm
79
BuildRequires:  pkg-config
80
BuildRequires:  pkgconfig(alsa)
81
BuildRequires:  pkgconfig(bzip2)
82
BuildRequires:  pkgconfig(celt) >= 0.11.0
83
BuildRequires:  pkgconfig(enca)
84
BuildRequires:  pkgconfig(fontconfig) >= 2.4.2
85
BuildRequires:  pkgconfig(freetype2)
86
BuildRequires:  pkgconfig(fribidi) >= 0.19.0
87
BuildRequires:  pkgconfig(gnutls)
88
BuildRequires:  pkgconfig(jack)
89
BuildRequires:  pkgconfig(libass)
90
BuildRequires:  pkgconfig(libbluray)
91
BuildRequires:  pkgconfig(libcdio)
92
BuildRequires:  pkgconfig(libcdio_paranoia)
93
BuildRequires:  pkgconfig(libdc1394-2)
94
BuildRequires:  pkgconfig(liboil-0.3) >= 0.3.15
95
BuildRequires:  pkgconfig(libpulse)
96
BuildRequires:  pkgconfig(libraw1394)
97
BuildRequires:  pkgconfig(libva) >= 0.35.0
98
BuildRequires:  pkgconfig(libwebp) >= 0.4
99
BuildRequires:  pkgconfig(ogg)
100
BuildRequires:  pkgconfig(opus)
101
BuildRequires:  pkgconfig(speex)
102
BuildRequires:  pkgconfig(theora) >= 1.1
103
BuildRequires:  pkgconfig(twolame)
104
BuildRequires:  pkgconfig(vdpau)
105
%if %{with vidstab}
106
BuildRequires:  pkgconfig(vidstab) >= 0.98
107
%endif
108
BuildRequires:  pkgconfig(vorbis)
109
BuildRequires:  pkgconfig(vpx) >= 1.3.0
110
BuildRequires:  pkgconfig(x11)
111
BuildRequires:  pkgconfig(xcb)
112
BuildRequires:  pkgconfig(xcb-render)
113
BuildRequires:  pkgconfig(xcb-shape)
114
BuildRequires:  pkgconfig(xcb-shm)
115
BuildRequires:  pkgconfig(xcb-xfixes)
116
BuildRequires:  pkgconfig(xext)
117
BuildRequires:  pkgconfig(xfixes)
118
%if %{with zimg}
119
BuildRequires:  pkgconfig(zimg)
120
%endif
121
BuildRequires:  pkgconfig(zlib)
122
BuildRequires:  pkgconfig(zvbi-0.2)
123
BuildRequires:  pkgconfig(libopenjp2)
124
BuildRequires:  pkgconfig(sdl2)
125
%if %{with fdk_aac}
126
BuildRequires:  pkgconfig(fdk-aac)
127
%endif
128
%if %{with librtmp}
129
BuildRequires:  pkgconfig(librtmp)
130
%endif
131
%if %{with xvid}
132
BuildRequires:  libxvidcore-devel
133
%endif
134
%if %{with opencore}
135
BuildRequires:  pkgconfig(opencore-amrnb)
136
%endif
137
%if %{with x264}
138
BuildRequires:  pkgconfig(x264)
139
%endif
140
%if %{with x265}
141
BuildRequires:  pkgconfig(x265)
142
%endif
143
Provides:       ffmpeg-tools = %version-%release
144
Obsoletes:      ffmpeg-tools < %version-%release
145
Provides:       ffmpeg = %version-%release
146
Obsoletes:      ffmpeg < %version-%release
147
Requires:       libavcodec57 = %version-%release
148
Requires:       libavdevice57 = %version-%release
149
Requires:       libavfilter6 = %version-%release
150
Requires:       libavformat57 = %version-%release
151
Requires:       libavresample3 = %version-%release
152
Requires:       libavutil55 = %version-%release
153
Requires:       libpostproc54 = %version-%release
154
Requires:       libswresample2 = %version-%release
155
Requires:       libswscale4 = %version-%release
156
157
%description
158
FFmpeg is a multimedia framework, able to decode, encode,
159
transcode, mux, demux, stream, filter and play several formats
160
that humans and machines have created.
161
162
%package -n libavcodec57
163
Summary:        FFmpeg codec library
164
# For mozillas
165
Group:          System/Libraries
166
Requires:       libavutil55 = %version-%release
167
Requires:       libswresample2 = %version-%release
168
Provides:       libavcodec = %version-%release
169
Provides:       libavcodec-full = %version-%release
170
# This can be required by packages likes vlc-codecs - following the shlib name to not get random lib providers
171
Provides:       libavcodec57(unrestricted)
172
173
%description -n libavcodec57
174
The libavcodec library provides a generic encoding/decoding framework
175
and contains multiple decoders and encoders for audio, video and
176
subtitle streams, and several bitstream filters.
177
178
%package libavcodec-devel
179
Summary:        Development files for FFmpeg's codec library
180
Group:          Development/Libraries/C and C++
181
Provides:       libavcodec-devel = %version-%release
182
Obsoletes:      libavcodec-devel < %version-%release
183
Requires:       %{name}-libavresample-devel = %version-%release
184
Requires:       %{name}-libavutil-devel = %version-%release
185
Requires:       libavcodec57 = %version-%release
186
%devel_conflicts -c < -v %{_major_version}
187
%devel_conflicts -c >= -v %{_major_expected}
188
189
%description libavcodec-devel
190
The libavcodec library provides a generic encoding/decoding framework
191
and contains multiple decoders and encoders for audio, video and
192
subtitle streams, and several bitstream filters.
193
194
This subpackage contains the headers for FFmpeg libavcodec.
195
196
%package -n libavdevice57
197
Summary:        FFmpeg device library
198
Group:          System/Libraries
199
Requires:       libavcodec57 = %version-%release
200
Requires:       libavfilter6 = %version-%release
201
Requires:       libavformat57 = %version-%release
202
Requires:       libavutil55 = %version-%release
203
204
%description -n libavdevice57
205
The libavdevice library provides a generic framework for grabbing from
206
and rendering to many common multimedia input/output devices, and
207
supports several input and output devices, including Video4Linux2, VfW,
208
DShow, and ALSA.
209
210
%package libavdevice-devel
211
Summary:        Development files for FFmpeg's device library
212
Group:          Development/Libraries/C and C++
213
Provides:       ffmpeg-devel = %version-%release
214
Conflicts:      ffmpeg-devel
215
Provides:       ffmpeg3-devel = %version-%release
216
Obsoletes:      ffmpeg3-devel < %version-%release
217
Provides:       libavdevice-devel = %version-%release
218
Obsoletes:      libavdevice-devel < %version-%release
219
Requires:       %{name}-libavcodec-devel = %version-%release
220
Requires:       %{name}-libavfilter-devel = %version-%release
221
Requires:       %{name}-libavformat-devel = %version-%release
222
Requires:       %{name}-libavresample-devel = %version-%release
223
Requires:       %{name}-libavutil-devel = %version-%release
224
Requires:       %{name}-libpostproc-devel = %version-%release
225
Requires:       %{name}-libswresample-devel = %version-%release
226
Requires:       %{name}-libswscale-devel = %version-%release
227
Requires:       libavdevice57 = %version-%release
228
%devel_conflicts -c < -v %{_major_version}
229
%devel_conflicts -c >= -v %{_major_expected}
230
231
%description libavdevice-devel
232
The libavdevice library provides a generic framework for grabbing from
233
and rendering to many common multimedia input/output devices, and
234
supports several input and output devices, including Video4Linux2, VfW,
235
DShow, and ALSA.
236
237
This subpackage contains the headers for FFmpeg libavcodec.
238
239
%package -n libavfilter6
240
Summary:        FFmpeg audio and video filtering library
241
Group:          System/Libraries
242
Requires:       libavcodec57 = %version-%release
243
Requires:       libavformat57 = %version-%release
244
Requires:       libavresample3 = %version-%release
245
Requires:       libavutil55 = %version-%release
246
Requires:       libpostproc54 = %version-%release
247
Requires:       libswresample2 = %version-%release
248
Requires:       libswscale4 = %version-%release
249
250
%description -n libavfilter6
251
The libavfilter library provides a generic audio/video filtering
252
framework containing several filters, sources and sinks.
253
254
%package libavfilter-devel
255
Summary:        Development files for FFmpeg's audio/video filter library
256
Group:          Development/Libraries/C and C++
257
Provides:       libavfilter-devel = %version-%release
258
Obsoletes:      libavfilter-devel < %version-%release
259
Requires:       %{name}-libavcodec-devel = %version-%release
260
Requires:       %{name}-libavformat-devel = %version-%release
261
Requires:       %{name}-libavresample-devel = %version-%release
262
Requires:       %{name}-libavutil-devel = %version-%release
263
Requires:       %{name}-libpostproc-devel = %version-%release
264
Requires:       %{name}-libswresample-devel = %version-%release
265
Requires:       %{name}-libswscale-devel = %version-%release
266
Requires:       libavfilter6 = %version-%release
267
%devel_conflicts -c < -v %{_major_version}
268
%devel_conflicts -c >= -v %{_major_expected}
269
270
%description libavfilter-devel
271
The libavfilter library provides a generic audio/video filtering
272
framework containing several filters, sources and sinks.
273
274
This subpackage contains the headers for FFmpeg libavfilter.
275
276
%package -n libavformat57
277
Summary:        FFmpeg's stream format library
278
Group:          System/Libraries
279
Requires:       libavcodec57 = %version-%release
280
Requires:       libavutil55 = %version-%release
281
282
%description -n libavformat57
283
The libavformat library provides a generic framework for multiplexing
284
and demultiplexing (muxing and demuxing) audio, video and subtitle
285
streams. It encompasses multiple muxers and demuxers for multimedia
286
container formats.
287
288
%package libavformat-devel
289
Summary:        Development files for FFmpeg's stream format library
290
Group:          Development/Libraries/C and C++
291
Provides:       libavformat-devel = %version-%release
292
Obsoletes:      libavformat-devel < %version-%release
293
Requires:       %{name}-libavcodec-devel = %version-%release
294
Requires:       %{name}-libavutil-devel = %version-%release
295
Requires:       %{name}-libswresample-devel = %version-%release
296
Requires:       libavformat57 = %version-%release
297
%devel_conflicts -c < -v %{_major_version}
298
%devel_conflicts -c >= -v %{_major_expected}
299
300
%description libavformat-devel
301
The libavformat library provides a generic framework for multiplexing
302
and demultiplexing (muxing and demuxing) audio, video and subtitle
303
streams. It encompasses multiple muxers and demuxers for multimedia
304
container formats.
305
306
This subpackage contains the headers for FFmpeg libavformat.
307
308
%package -n libavresample3
309
Summary:        FFmpeg alternate audio resampling library
310
Group:          System/Libraries
311
Requires:       libavutil55 = %version-%release
312
313
%description -n libavresample3
314
An audio resampling library that is being provided for drop-in
315
compatibility with libav.
316
317
It is advised to use libswresample for new code.
318
319
%package libavresample-devel
320
Summary:        Development files for libavresample as present in FFmpeg
321
Group:          Development/Libraries/C and C++
322
Provides:       libavresample-devel = %version-%release
323
Obsoletes:      libavresample-devel < %version-%release
324
Requires:       %{name}-libavutil-devel = %version-%release
325
Requires:       libavresample3 = %version-%release
326
%devel_conflicts -c < -v %{_major_version}
327
%devel_conflicts -c >= -v %{_major_expected}
328
329
%description libavresample-devel
330
An audio resampling library that is being provided for drop-in
331
compatibility with libav.
332
333
It is advised to use libswresample for new code.
334
335
This subpackage contains the headers for FFmpeg's copy of libavresample.
336
337
%package -n libavutil55
338
Summary:        FFmpeg's utility library
339
Group:          System/Libraries
340
341
%description -n libavutil55
342
The libavutil library is a utility library to aid portable multimedia
343
programming. It contains safe portable string functions, random
344
number generators, data structures, additional mathematics functions,
345
cryptography and multimedia related functionality (like enumerations
346
for pixel and sample formats).
347
348
%package libavutil-devel
349
Summary:        Development files for FFmpeg's utility library
350
Group:          Development/Libraries/C and C++
351
Provides:       libavutil-devel = %version-%release
352
Obsoletes:      libavutil-devel < %version-%release
353
Requires:       libavutil55 = %version-%release
354
%devel_conflicts -c < -v %{_major_version}
355
%devel_conflicts -c >= -v %{_major_expected}
356
357
%description libavutil-devel
358
The libavutil library is a utility library to aid portable multimedia
359
programming. It contains safe portable string functions, random
360
number generators, data structures, additional mathematics functions,
361
cryptography and multimedia related functionality (like enumerations
362
for pixel and sample formats).
363
364
This subpackage contains the headers for FFmpeg libavutil.
365
366
%package -n libpostproc54
367
Summary:        FFmpeg post-processing library
368
Group:          System/Libraries
369
Requires:       libavutil55 = %version-%release
370
371
%description -n libpostproc54
372
A library with video postprocessing filters, such as deblocking and
373
deringing filters, noise reduction, automatic contrast and brightness
374
correction, linear/cubic interpolating deinterlacing.
375
376
%package libpostproc-devel
377
Summary:        Development files for the FFmpeg post-processing library
378
Group:          Development/Libraries/C and C++
379
Provides:       libpostproc-devel = %version-%release
380
Obsoletes:      libpostproc-devel < %version-%release
381
Requires:       %{name}-libavutil-devel = %version-%release
382
Requires:       libpostproc54 = %version-%release
383
%devel_conflicts -c < -v %{_major_version}
384
%devel_conflicts -c >= -v %{_major_expected}
385
386
%description libpostproc-devel
387
A library with video postprocessing filters, such as deblocking and
388
deringing filters, noise reduction, automatic contrast and brightness
389
correction, linear/cubic interpolating deinterlacing.
390
391
This subpackage contains the headers for FFmpeg libpostproc.
392
393
%package -n libswresample2
394
Summary:        FFmpeg software resampling library
395
Group:          System/Libraries
396
Requires:       libavutil55 = %version-%release
397
398
%description -n libswresample2
399
The libswresample library performs audio conversion between different
400
sample rates, channel layout and channel formats.
401
402
%package libswresample-devel
403
Summary:        Development files for the FFmpeg software resampling library
404
Group:          Development/Libraries/C and C++
405
Provides:       libswresample-devel = %version-%release
406
Obsoletes:      libswresample-devel < %version-%release
407
Requires:       %{name}-libavutil-devel = %version-%release
408
Requires:       libswresample2 = %version-%release
409
%devel_conflicts -c < -v %{_major_version}
410
%devel_conflicts -c >= -v %{_major_expected}
411
412
%description libswresample-devel
413
The libswresample library performs audio conversion between different
414
sample rates, channel layout and channel formats.
415
416
This subpackage contains the headers for FFmpeg libswresample.
417
418
%package -n libswscale4
419
Summary:        FFmpeg image scaling and colorspace/pixel conversion library
420
Group:          System/Libraries
421
Requires:       libavutil55 = %version-%release
422
423
%description -n libswscale4
424
The libswscale library performs image scaling and colorspace and
425
pixel format conversion operations.
426
427
%package libswscale-devel
428
Summary:        Development files for FFmpeg's image scaling and colorspace library
429
Group:          Development/Libraries/C and C++
430
Provides:       libswscale-devel = %version-%release
431
Conflicts:      libswscale-devel
432
Requires:       %{name}-libavutil-devel = %version-%release
433
Requires:       libswscale4 = %version-%release
434
%devel_conflicts -c < -v %{_major_version}
435
%devel_conflicts -c >= -v %{_major_expected}
436
437
%description libswscale-devel
438
The libswscale library performs image scaling and colorspace and
439
pixel format conversion operations.
440
441
This subpackage contains the headers for FFmpeg libswscale.
442
443
%package private-devel
444
Summary:        Some FFmpeg private headers
445
Group:          Development/Libraries/C and C++
446
Requires:       %{name}-libavcodec-devel = %version-%release
447
Requires:       %{name}-libavformat-devel = %version-%release
448
Requires:       %{name}-libavutil-devel = %version-%release
449
Provides:       ffmpeg-private-devel = %version
450
Obsoletes:      ffmpeg-private-devel < %version
451
%devel_conflicts -c < -v %{_major_version}
452
%devel_conflicts -c >= -v %{_major_expected}
453
454
%description private-devel
455
FFmpeg is a multimedia framework, able to decode, encode,
456
transcode, mux, demux, stream, filter and play several formats
457
that humans and machines have created.
458
459
This package contains some private headers for libavformat, libavcodec and
460
libavutil which are needed by libav-tools to build. No other package apart
461
from libav should depend on these private headers which are expected to
462
break compatibility without any notice.
463
464
%prep
465
%autosetup -p1
466
467
%build
468
echo '%version' > VERSION
469
perl -i -pe 's{__TIME__|__DATE__}{"$&"}g' *.c
470
471
if \
472
env \
473
CFLAGS="%optflags" \
474
./configure \
475
    --prefix="%_prefix" --libdir="%_libdir" --shlibdir="%_libdir" \
476
    --incdir="%_includedir/ffmpeg" \
477
    --extra-cflags="%optflags" --optflags="%optflags" \
478
    --disable-htmlpages \
479
    --enable-pic --disable-stripping \
480
    --enable-shared --disable-static \
481
    --enable-gpl \
482
    --disable-openssl \
483
    --enable-avresample \
484
    --enable-libcdio \
485
    --enable-gnutls \
486
    --enable-ladspa \
487
%if %{without nvidia}
488
    --disable-cuda \
489
    --disable-cuvid \
490
%endif
491
    --enable-libass \
492
    --enable-libbluray \
493
    --enable-libcelt \
494
    --enable-libcdio \
495
    --enable-libdc1394 \
496
    --enable-libfreetype \
497
    --enable-libgsm \
498
    --enable-libmp3lame \
499
    --enable-libopenjpeg \
500
    --enable-libopus \
501
    --enable-libpulse \
502
    --enable-libspeex \
503
    --enable-libtheora \
504
    --enable-libtwolame \
505
%if %{with vidstab}
506
    --enable-libvidstab \
507
%endif
508
    --enable-libvorbis \
509
    --enable-libvpx \
510
    --enable-libwebp \
511
%if %{with zimg}
512
    --enable-libzimg \
513
%endif
514
    --enable-libzvbi \
515
    --enable-vaapi \
516
    --enable-vdpau \
517
%if %{with fdk_aac}
518
    --enable-libfdk_aac --enable-nonfree \
519
%endif
520
%if %{with opencore}
521
    --enable-libopencore-amrnb \
522
    --enable-libopencore-amrwb \
523
    --enable-version3 \
524
%endif
525
%if %{with x264}
526
    --enable-libx264 \
527
%endif
528
%if %{with x265}
529
    --enable-libx265 \
530
%endif
531
%if %{with xvid}
532
    --enable-libxvid \
533
%endif
534
    %{nil}
535
then
536
    : good
537
else
538
    : bad
539
    cat ffbuild/config.log
540
    exit 1
541
fi
542
543
cat config.h
544
%make_build
545
546
%global extratools aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper probetest qt-faststart seek_print sidxindex trasher
547
548
for i in %extratools; do
549
    make "tools/$i"
550
done
551
552
%install
553
b="%buildroot"
554
%make_install install-man
555
556
%if %{with ffmpeg3_full_build}
557
rm -Rf "$b/%_datadir/ffmpeg/examples"
558
for i in %extratools; do
559
    cp -a "tools/$i" "$b/%_bindir/"
560
done
561
%else
562
rm -Rf "$b/%_bindir" "$b/%_mandir/man1" "$b/%_datadir/ffmpeg"
563
%endif
564
565
# Install private headers required by libav-tools
566
for i in libavformat/options_table.h libavformat/os_support.h \
567
  libavformat/internal.h libavcodec/options_table.h libavutil/libm.h \
568
  libavutil/internal.h libavutil/colorspace.h libavutil/timer.h \
569
  libavutil/x86/emms.h libavutil/aarch64/timer.h libavutil/arm/timer.h \
570
  libavutil/bfin/timer.h libavutil/ppc/timer.h libavutil/x86/timer.h; do
571
    mkdir -p "$b/%_includedir/ffmpeg/private/"`dirname $i`
572
    cp -a $i "$b/%_includedir/ffmpeg/private/$i"
573
done
574
575
%post   -n libavcodec57 -p /sbin/ldconfig
576
%postun -n libavcodec57 -p /sbin/ldconfig
577
%post   -n libavdevice57 -p /sbin/ldconfig
578
%postun -n libavdevice57 -p /sbin/ldconfig
579
%post   -n libavfilter6 -p /sbin/ldconfig
580
%postun -n libavfilter6 -p /sbin/ldconfig
581
%post   -n libavformat57 -p /sbin/ldconfig
582
%postun -n libavformat57 -p /sbin/ldconfig
583
%post   -n libavresample3 -p /sbin/ldconfig
584
%postun -n libavresample3 -p /sbin/ldconfig
585
%post   -n libavutil55 -p /sbin/ldconfig
586
%postun -n libavutil55 -p /sbin/ldconfig
587
%post   -n libpostproc54 -p /sbin/ldconfig
588
%postun -n libpostproc54 -p /sbin/ldconfig
589
%post   -n libswresample2 -p /sbin/ldconfig
590
%postun -n libswresample2 -p /sbin/ldconfig
591
%post   -n libswscale4 -p /sbin/ldconfig
592
%postun -n libswscale4 -p /sbin/ldconfig
593
594
%if %{with ffmpeg3_full_build}
595
%files
596
%doc CREDITS README.md
597
%_bindir/*
598
%_mandir/man1/ff*.1*
599
%_datadir/ffmpeg/
600
%endif
601
602
%files -n libavcodec57
603
%_libdir/libavcodec.so.*
604
605
%files -n libavdevice57
606
%_libdir/libavdevice.so.*
607
608
%files -n libavfilter6
609
%_libdir/libavfilter.so.*
610
611
%files -n libavformat57
612
%_libdir/libavformat.so.*
613
614
%files -n libavresample3
615
%_libdir/libavresample.so.*
616
617
%files -n libavutil55
618
%doc Changelog
619
%license COPYING.GPLv2 LICENSE.md
620
%_libdir/libavutil.so.*
621
622
%files -n libpostproc54
623
%_libdir/libpostproc.so.*
624
625
%files -n libswresample2
626
%_libdir/libswresample.so.*
627
628
%files -n libswscale4
629
%_libdir/libswscale.so.*
630
631
%files libavcodec-devel
632
%dir %_includedir/ffmpeg/
633
%_includedir/ffmpeg/libavcodec/
634
%_libdir/libavcodec.so
635
%_libdir/pkgconfig/libavcodec.pc
636
%_mandir/man3/libavcodec.3*
637
638
%files libavdevice-devel
639
%dir %_includedir/ffmpeg/
640
%_includedir/ffmpeg/libavdevice/
641
%_libdir/libavdevice.so
642
%_libdir/pkgconfig/libavdevice.pc
643
%_mandir/man3/libavdevice.3*
644
645
%files libavfilter-devel
646
%dir %_includedir/ffmpeg/
647
%_includedir/ffmpeg/libavfilter/
648
%_libdir/libavfilter.so
649
%_libdir/pkgconfig/libavfilter.pc
650
%_mandir/man3/libavfilter.3*
651
652
%files libavformat-devel
653
%dir %_includedir/ffmpeg/
654
%_includedir/ffmpeg/libavformat/
655
%_libdir/libavformat.so
656
%_libdir/pkgconfig/libavformat.pc
657
%_mandir/man3/libavformat.3*
658
659
%files libavresample-devel
660
%dir %_includedir/ffmpeg/
661
%_includedir/ffmpeg/libavresample/
662
%_libdir/libavresample.so
663
%_libdir/pkgconfig/libavresample.pc
664
665
%files libavutil-devel
666
%dir %_includedir/ffmpeg/
667
%_includedir/ffmpeg/libavutil/
668
%_libdir/libavutil.so
669
%_libdir/pkgconfig/libavutil.pc
670
%_mandir/man3/libavutil.3*
671
672
%files libpostproc-devel
673
%dir %_includedir/ffmpeg/
674
%_includedir/ffmpeg/libpostproc/
675
%_libdir/libpostproc.so
676
%_libdir/pkgconfig/libpostproc.pc
677
678
%files libswresample-devel
679
%dir %_includedir/ffmpeg/
680
%_includedir/ffmpeg/libswresample/
681
%_libdir/libswresample.so
682
%_libdir/pkgconfig/libswresample.pc
683
%_mandir/man3/libswresample.3*
684
685
%files libswscale-devel
686
%dir %_includedir/ffmpeg/
687
%_includedir/ffmpeg/libswscale/
688
%_libdir/libswscale.so
689
%_libdir/pkgconfig/libswscale.pc
690
%_mandir/man3/libswscale.3*
691
692
%files private-devel
693
%_includedir/ffmpeg/private/
694
695
%changelog
696