File ffmpeg-3.spec of Package A_tw-ffmpeg-3

697
 
1
#
2
# spec file for package ffmpeg-3
3
#
4
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
%define _lto_cflags %{nil}
20
# Create proper conflicts to make sure we require all from one version
21
# p:   Conflict string, eg if you need them all for requires instead
22
#      Default value Conflicts:
23
# c:   copmare string ie "<" or ">=", must be defined
24
# v:   version string ie. "< 42.3.4" or ">= 15.0.2.1", must be defined
25
%define devel_conflicts(p:c:v:) \
26
%define preamble_string %{-p:%{-p*}}%{!-p:Conflicts:} \
27
%define comparator %{-c:%{-c*}}%{!-c:%{error:Comparator not defined}} \
28
%define conflicts_version %{-v:%{-v*}}%{!-v:%{error:Version not defined}} \
29
\
30
%{preamble_string} libavcodec-devel %{comparator} %{conflicts_version} \
31
%{preamble_string} libavdevice-devel %{comparator} %{conflicts_version} \
32
%{preamble_string} libavfilter-devel %{comparator} %{conflicts_version} \
33
%{preamble_string} libavformat-devel %{comparator} %{conflicts_version} \
34
%{preamble_string} libavresample-devel %{comparator} %{conflicts_version} \
35
%{preamble_string} libavutil-devel %{comparator} %{conflicts_version} \
36
%{preamble_string} libpostproc-devel %{comparator} %{conflicts_version} \
37
%{preamble_string} libswresample-devel %{comparator} %{conflicts_version} \
38
%{preamble_string} libswscale-devel %{comparator} %{conflicts_version} \
39
%{preamble_string} ffmpeg-private-devel %{comparator} %{conflicts_version} \
40
%{nil}
41
42
%bcond_with    fdk_aac
43
%bcond_without librtmp
44
%bcond_without nvidia
45
%bcond_without opencore
46
%bcond_without vidstab
47
%bcond_without vo_aacenc
48
%bcond_without x264
49
%bcond_without x265
50
%bcond_without xvid
51
%bcond_without zimg
52
%bcond_without ffmpeg3_full_build
53
54
55
%define _major_version 3
56
%define _major_expected 4
57
Name:           ffmpeg-3
58
Version:        3.4.13
59
Release:        0
60
Summary:        Library for working with various multimedia formats
61
License:        LGPL-2.1-or-later AND GPL-2.0-or-later
62
Group:          Productivity/Multimedia/Video/Editors and Convertors
63
Url:            https://git.ffmpeg.org/gitweb/ffmpeg.git
64
Source:         %name-%version.tar.xz
65
Source3:        %name-rpmlintrc
66
Source4:        enable_decoders
67
Source5:        enable_encoders
68
Source99:       baselibs.conf
69
Patch0:         %name.patch
70
Patch1:         ffmpeg-libcdio_cdda-pkgconfig.patch
71
Patch2:         ffmpeg-arm6l.diff
72
Patch3:         ffmpeg-libopenjpeg.patch
73
Patch4:         ffmpeg-codec-choice.diff
74
Patch6:         0001-opusenc-psy-disable-stereo-searches.patch
75
Patch7:         ffmpeg-fix-build-fdk-aac2.patch
76
Patch8:         ffmpeg-x86-mathops.patch
77
BuildRequires:  ladspa-devel
78
BuildRequires:  libgsm-devel
79
BuildRequires:  libmp3lame-devel
80
BuildRequires:  nasm
81
BuildRequires:  pkg-config
82
BuildRequires:  pkgconfig(alsa)
83
BuildRequires:  pkgconfig(bzip2)
84
BuildRequires:  pkgconfig(celt) >= 0.11.0
85
BuildRequires:  pkgconfig(enca)
86
BuildRequires:  pkgconfig(fontconfig) >= 2.4.2
87
BuildRequires:  pkgconfig(freetype2)
88
BuildRequires:  pkgconfig(fribidi) >= 0.19.0
89
BuildRequires:  pkgconfig(gnutls)
90
BuildRequires:  pkgconfig(jack)
91
BuildRequires:  pkgconfig(libass)
92
BuildRequires:  pkgconfig(libbluray)
93
BuildRequires:  pkgconfig(libcdio)
94
BuildRequires:  pkgconfig(libcdio_paranoia)
95
BuildRequires:  pkgconfig(libdc1394-2)
96
BuildRequires:  pkgconfig(libpulse)
97
BuildRequires:  pkgconfig(libraw1394)
98
BuildRequires:  pkgconfig(libva) >= 0.35.0
99
BuildRequires:  pkgconfig(libwebp) >= 0.4
100
BuildRequires:  pkgconfig(ogg)
101
BuildRequires:  pkgconfig(opus)
102
BuildRequires:  pkgconfig(speex)
103
BuildRequires:  pkgconfig(theora) >= 1.1
104
BuildRequires:  pkgconfig(twolame)
105
BuildRequires:  pkgconfig(vdpau)
106
%if %{with vidstab}
107
BuildRequires:  pkgconfig(vidstab) >= 0.98
108
%endif
109
BuildRequires:  pkgconfig(vorbis)
110
BuildRequires:  pkgconfig(vpx) >= 1.3.0
111
BuildRequires:  pkgconfig(x11)
112
BuildRequires:  pkgconfig(xcb)
113
BuildRequires:  pkgconfig(xcb-render)
114
BuildRequires:  pkgconfig(xcb-shape)
115
BuildRequires:  pkgconfig(xcb-shm)
116
BuildRequires:  pkgconfig(xcb-xfixes)
117
BuildRequires:  pkgconfig(xext)
118
BuildRequires:  pkgconfig(xfixes)
119
%if %{with zimg}
120
BuildRequires:  pkgconfig(zimg)
121
%endif
122
BuildRequires:  pkgconfig(zlib)
123
BuildRequires:  pkgconfig(zvbi-0.2)
124
BuildRequires:  pkgconfig(libopenjp2)
125
BuildRequires:  pkgconfig(sdl2)
126
%if %{with fdk_aac}
127
BuildRequires:  pkgconfig(fdk-aac)
128
%endif
129
%if %{with librtmp}
130
BuildRequires:  pkgconfig(librtmp)
131
%endif
132
%if %{with xvid}
133
BuildRequires:  libxvidcore-devel
134
%endif
135
%if %{with opencore}
136
BuildRequires:  pkgconfig(opencore-amrnb)
137
%endif
138
%if %{with x264}
139
BuildRequires:  pkgconfig(x264)
140
%endif
141
%if %{with x265}
142
BuildRequires:  pkgconfig(x265)
143
%endif
144
Provides:       ffmpeg-tools = %version-%release
145
Obsoletes:      ffmpeg-tools < %version-%release
146
Provides:       ffmpeg = %version-%release
147
Obsoletes:      ffmpeg < %version-%release
148
Requires:       libavcodec57 = %version-%release
149
Requires:       libavdevice57 = %version-%release
150
Requires:       libavfilter6 = %version-%release
151
Requires:       libavformat57 = %version-%release
152
Requires:       libavresample3 = %version-%release
153
Requires:       libavutil55 = %version-%release
154
Requires:       libpostproc54 = %version-%release
155
Requires:       libswresample2 = %version-%release
156
Requires:       libswscale4 = %version-%release
157
158
%description
159
FFmpeg is a multimedia framework, able to decode, encode,
160
transcode, mux, demux, stream, filter and play several formats
161
that humans and machines have created.
162
163
%package -n libavcodec57
164
Summary:        FFmpeg codec library
165
# For mozillas
166
Group:          System/Libraries
167
Requires:       libavutil55 = %version-%release
168
Requires:       libswresample2 = %version-%release
169
Provides:       libavcodec = %version-%release
170
Provides:       libavcodec-full = %version-%release
171
# This can be required by packages likes vlc-codecs - following the shlib name to not get random lib providers
172
Provides:       libavcodec57(unrestricted)
173
174
%description -n libavcodec57
175
The libavcodec library provides a generic encoding/decoding framework
176
and contains multiple decoders and encoders for audio, video and
177
subtitle streams, and several bitstream filters.
178
179
%package libavcodec-devel
180
Summary:        Development files for FFmpeg's codec library
181
Group:          Development/Libraries/C and C++
182
Provides:       libavcodec-devel = %version-%release
183
Obsoletes:      libavcodec-devel < %version-%release
184
Requires:       %{name}-libavresample-devel = %version-%release
185
Requires:       %{name}-libavutil-devel = %version-%release
186
Requires:       libavcodec57 = %version-%release
187
%devel_conflicts -c < -v %{_major_version}
188
%devel_conflicts -c >= -v %{_major_expected}
189
190
%description libavcodec-devel
191
The libavcodec library provides a generic encoding/decoding framework
192
and contains multiple decoders and encoders for audio, video and
193
subtitle streams, and several bitstream filters.
194
195
This subpackage contains the headers for FFmpeg libavcodec.
196
197
%package -n libavdevice57
198
Summary:        FFmpeg device library
199
Group:          System/Libraries
200
Requires:       libavcodec57 = %version-%release
201
Requires:       libavfilter6 = %version-%release
202
Requires:       libavformat57 = %version-%release
203
Requires:       libavutil55 = %version-%release
204
205
%description -n libavdevice57
206
The libavdevice library provides a generic framework for grabbing from
207
and rendering to many common multimedia input/output devices, and
208
supports several input and output devices, including Video4Linux2, VfW,
209
DShow, and ALSA.
210
211
%package libavdevice-devel
212
Summary:        Development files for FFmpeg's device library
213
Group:          Development/Libraries/C and C++
214
Provides:       ffmpeg-devel = %version-%release
215
Conflicts:      ffmpeg-devel
216
Provides:       ffmpeg3-devel = %version-%release
217
Obsoletes:      ffmpeg3-devel < %version-%release
218
Provides:       libavdevice-devel = %version-%release
219
Obsoletes:      libavdevice-devel < %version-%release
220
Requires:       %{name}-libavcodec-devel = %version-%release
221
Requires:       %{name}-libavfilter-devel = %version-%release
222
Requires:       %{name}-libavformat-devel = %version-%release
223
Requires:       %{name}-libavresample-devel = %version-%release
224
Requires:       %{name}-libavutil-devel = %version-%release
225
Requires:       %{name}-libpostproc-devel = %version-%release
226
Requires:       %{name}-libswresample-devel = %version-%release
227
Requires:       %{name}-libswscale-devel = %version-%release
228
Requires:       libavdevice57 = %version-%release
229
%devel_conflicts -c < -v %{_major_version}
230
%devel_conflicts -c >= -v %{_major_expected}
231
232
%description libavdevice-devel
233
The libavdevice library provides a generic framework for grabbing from
234
and rendering to many common multimedia input/output devices, and
235
supports several input and output devices, including Video4Linux2, VfW,
236
DShow, and ALSA.
237
238
This subpackage contains the headers for FFmpeg libavcodec.
239
240
%package -n libavfilter6
241
Summary:        FFmpeg audio and video filtering library
242
Group:          System/Libraries
243
Requires:       libavcodec57 = %version-%release
244
Requires:       libavformat57 = %version-%release
245
Requires:       libavresample3 = %version-%release
246
Requires:       libavutil55 = %version-%release
247
Requires:       libpostproc54 = %version-%release
248
Requires:       libswresample2 = %version-%release
249
Requires:       libswscale4 = %version-%release
250
251
%description -n libavfilter6
252
The libavfilter library provides a generic audio/video filtering
253
framework containing several filters, sources and sinks.
254
255
%package libavfilter-devel
256
Summary:        Development files for FFmpeg's audio/video filter library
257
Group:          Development/Libraries/C and C++
258
Provides:       libavfilter-devel = %version-%release
259
Obsoletes:      libavfilter-devel < %version-%release
260
Requires:       %{name}-libavcodec-devel = %version-%release
261
Requires:       %{name}-libavformat-devel = %version-%release
262
Requires:       %{name}-libavresample-devel = %version-%release
263
Requires:       %{name}-libavutil-devel = %version-%release
264
Requires:       %{name}-libpostproc-devel = %version-%release
265
Requires:       %{name}-libswresample-devel = %version-%release
266
Requires:       %{name}-libswscale-devel = %version-%release
267
Requires:       libavfilter6 = %version-%release
268
%devel_conflicts -c < -v %{_major_version}
269
%devel_conflicts -c >= -v %{_major_expected}
270
271
%description libavfilter-devel
272
The libavfilter library provides a generic audio/video filtering
273
framework containing several filters, sources and sinks.
274
275
This subpackage contains the headers for FFmpeg libavfilter.
276
277
%package -n libavformat57
278
Summary:        FFmpeg's stream format library
279
Group:          System/Libraries
280
Requires:       libavcodec57 = %version-%release
281
Requires:       libavutil55 = %version-%release
282
283
%description -n libavformat57
284
The libavformat library provides a generic framework for multiplexing
285
and demultiplexing (muxing and demuxing) audio, video and subtitle
286
streams. It encompasses multiple muxers and demuxers for multimedia
287
container formats.
288
289
%package libavformat-devel
290
Summary:        Development files for FFmpeg's stream format library
291
Group:          Development/Libraries/C and C++
292
Provides:       libavformat-devel = %version-%release
293
Obsoletes:      libavformat-devel < %version-%release
294
Requires:       %{name}-libavcodec-devel = %version-%release
295
Requires:       %{name}-libavutil-devel = %version-%release
296
Requires:       %{name}-libswresample-devel = %version-%release
297
Requires:       libavformat57 = %version-%release
298
%devel_conflicts -c < -v %{_major_version}
299
%devel_conflicts -c >= -v %{_major_expected}
300
301
%description libavformat-devel
302
The libavformat library provides a generic framework for multiplexing
303
and demultiplexing (muxing and demuxing) audio, video and subtitle
304
streams. It encompasses multiple muxers and demuxers for multimedia
305
container formats.
306
307
This subpackage contains the headers for FFmpeg libavformat.
308
309
%package -n libavresample3
310
Summary:        FFmpeg alternate audio resampling library
311
Group:          System/Libraries
312
Requires:       libavutil55 = %version-%release
313
314
%description -n libavresample3
315
An audio resampling library that is being provided for drop-in
316
compatibility with libav.
317
318
It is advised to use libswresample for new code.
319
320
%package libavresample-devel
321
Summary:        Development files for libavresample as present in FFmpeg
322
Group:          Development/Libraries/C and C++
323
Provides:       libavresample-devel = %version-%release
324
Obsoletes:      libavresample-devel < %version-%release
325
Requires:       %{name}-libavutil-devel = %version-%release
326
Requires:       libavresample3 = %version-%release
327
%devel_conflicts -c < -v %{_major_version}
328
%devel_conflicts -c >= -v %{_major_expected}
329
330
%description libavresample-devel
331
An audio resampling library that is being provided for drop-in
332
compatibility with libav.
333
334
It is advised to use libswresample for new code.
335
336
This subpackage contains the headers for FFmpeg's copy of libavresample.
337
338
%package -n libavutil55
339
Summary:        FFmpeg's utility library
340
Group:          System/Libraries
341
342
%description -n libavutil55
343
The libavutil library is a utility library to aid portable multimedia
344
programming. It contains safe portable string functions, random
345
number generators, data structures, additional mathematics functions,
346
cryptography and multimedia related functionality (like enumerations
347
for pixel and sample formats).
348
349
%package libavutil-devel
350
Summary:        Development files for FFmpeg's utility library
351
Group:          Development/Libraries/C and C++
352
Provides:       libavutil-devel = %version-%release
353
Obsoletes:      libavutil-devel < %version-%release
354
Requires:       libavutil55 = %version-%release
355
%devel_conflicts -c < -v %{_major_version}
356
%devel_conflicts -c >= -v %{_major_expected}
357
358
%description libavutil-devel
359
The libavutil library is a utility library to aid portable multimedia
360
programming. It contains safe portable string functions, random
361
number generators, data structures, additional mathematics functions,
362
cryptography and multimedia related functionality (like enumerations
363
for pixel and sample formats).
364
365
This subpackage contains the headers for FFmpeg libavutil.
366
367
%package -n libpostproc54
368
Summary:        FFmpeg post-processing library
369
Group:          System/Libraries
370
Requires:       libavutil55 = %version-%release
371
372
%description -n libpostproc54
373
A library with video postprocessing filters, such as deblocking and
374
deringing filters, noise reduction, automatic contrast and brightness
375
correction, linear/cubic interpolating deinterlacing.
376
377
%package libpostproc-devel
378
Summary:        Development files for the FFmpeg post-processing library
379
Group:          Development/Libraries/C and C++
380
Provides:       libpostproc-devel = %version-%release
381
Obsoletes:      libpostproc-devel < %version-%release
382
Requires:       %{name}-libavutil-devel = %version-%release
383
Requires:       libpostproc54 = %version-%release
384
%devel_conflicts -c < -v %{_major_version}
385
%devel_conflicts -c >= -v %{_major_expected}
386
387
%description libpostproc-devel
388
A library with video postprocessing filters, such as deblocking and
389
deringing filters, noise reduction, automatic contrast and brightness
390
correction, linear/cubic interpolating deinterlacing.
391
392
This subpackage contains the headers for FFmpeg libpostproc.
393
394
%package -n libswresample2
395
Summary:        FFmpeg software resampling library
396
Group:          System/Libraries
397
Requires:       libavutil55 = %version-%release
398
399
%description -n libswresample2
400
The libswresample library performs audio conversion between different
401
sample rates, channel layout and channel formats.
402
403
%package libswresample-devel
404
Summary:        Development files for the FFmpeg software resampling library
405
Group:          Development/Libraries/C and C++
406
Provides:       libswresample-devel = %version-%release
407
Obsoletes:      libswresample-devel < %version-%release
408
Requires:       %{name}-libavutil-devel = %version-%release
409
Requires:       libswresample2 = %version-%release
410
%devel_conflicts -c < -v %{_major_version}
411
%devel_conflicts -c >= -v %{_major_expected}
412
413
%description libswresample-devel
414
The libswresample library performs audio conversion between different
415
sample rates, channel layout and channel formats.
416
417
This subpackage contains the headers for FFmpeg libswresample.
418
419
%package -n libswscale4
420
Summary:        FFmpeg image scaling and colorspace/pixel conversion library
421
Group:          System/Libraries
422
Requires:       libavutil55 = %version-%release
423
424
%description -n libswscale4
425
The libswscale library performs image scaling and colorspace and
426
pixel format conversion operations.
427
428
%package libswscale-devel
429
Summary:        Development files for FFmpeg's image scaling and colorspace library
430
Group:          Development/Libraries/C and C++
431
Provides:       libswscale-devel = %version-%release
432
Conflicts:      libswscale-devel
433
Requires:       %{name}-libavutil-devel = %version-%release
434
Requires:       libswscale4 = %version-%release
435
%devel_conflicts -c < -v %{_major_version}
436
%devel_conflicts -c >= -v %{_major_expected}
437
438
%description libswscale-devel
439
The libswscale library performs image scaling and colorspace and
440
pixel format conversion operations.
441
442
This subpackage contains the headers for FFmpeg libswscale.
443
444
%package private-devel
445
Summary:        Some FFmpeg private headers
446
Group:          Development/Libraries/C and C++
447
Requires:       %{name}-libavcodec-devel = %version-%release
448
Requires:       %{name}-libavformat-devel = %version-%release
449
Requires:       %{name}-libavutil-devel = %version-%release
450
Provides:       ffmpeg-private-devel = %version
451
Obsoletes:      ffmpeg-private-devel < %version
452
%devel_conflicts -c < -v %{_major_version}
453
%devel_conflicts -c >= -v %{_major_expected}
454
455
%description private-devel
456
FFmpeg is a multimedia framework, able to decode, encode,
457
transcode, mux, demux, stream, filter and play several formats
458
that humans and machines have created.
459
460
This package contains some private headers for libavformat, libavcodec and
461
libavutil which are needed by libav-tools to build. No other package apart
462
from libav should depend on these private headers which are expected to
463
break compatibility without any notice.
464
465
%prep
466
%autosetup -p1
467
468
%build
469
echo '%version' > VERSION
470
perl -i -pe 's{__TIME__|__DATE__}{"$&"}g' *.c
471
472
if \
473
env \
474
CFLAGS="%optflags" \
475
./configure \
476
    --prefix="%_prefix" --libdir="%_libdir" --shlibdir="%_libdir" \
477
    --incdir="%_includedir/ffmpeg" \
478
    --extra-cflags="%optflags" --optflags="%optflags" \
479
    --disable-htmlpages \
480
    --enable-pic --disable-stripping \
481
    --enable-shared --disable-static \
482
    --enable-gpl \
483
    --disable-openssl \
484
    --enable-avresample \
485
    --enable-libcdio \
486
    --enable-gnutls \
487
    --enable-ladspa \
488
%if %{without nvidia}
489
    --disable-cuda \
490
    --disable-cuvid \
491
%endif
492
    --enable-libass \
493
    --enable-libbluray \
494
    --enable-libcelt \
495
    --enable-libcdio \
496
    --enable-libdc1394 \
497
    --enable-libfreetype \
498
    --enable-libgsm \
499
    --enable-libmp3lame \
500
    --enable-libopenjpeg \
501
    --enable-libopus \
502
    --enable-libpulse \
503
    --enable-libspeex \
504
    --enable-libtheora \
505
    --enable-libtwolame \
506
%if %{with vidstab}
507
    --enable-libvidstab \
508
%endif
509
    --enable-libvorbis \
510
    --enable-libvpx \
511
    --enable-libwebp \
512
%if %{with zimg}
513
    --enable-libzimg \
514
%endif
515
    --enable-libzvbi \
516
    --enable-vaapi \
517
    --enable-vdpau \
518
%if %{with fdk_aac}
519
    --enable-libfdk_aac --enable-nonfree \
520
%endif
521
%if %{with opencore}
522
    --enable-libopencore-amrnb \
523
    --enable-libopencore-amrwb \
524
    --enable-version3 \
525
%endif
526
%if %{with x264}
527
    --enable-libx264 \
528
%endif
529
%if %{with x265}
530
    --enable-libx265 \
531
%endif
532
%if %{with xvid}
533
    --enable-libxvid \
534
%endif
535
    %{nil}
536
then
537
    : good
538
else
539
    : bad
540
    cat ffbuild/config.log
541
    exit 1
542
fi
543
544
cat config.h
545
%make_build
546
547
%global extratools aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper probetest qt-faststart seek_print sidxindex trasher
548
549
for i in %extratools; do
550
    make "tools/$i"
551
done
552
553
%install
554
b="%buildroot"
555
%make_install install-man
556
557
%if %{with ffmpeg3_full_build}
558
rm -Rf "$b/%_datadir/ffmpeg/examples"
559
for i in %extratools; do
560
    cp -a "tools/$i" "$b/%_bindir/"
561
done
562
%else
563
rm -Rf "$b/%_bindir" "$b/%_mandir/man1" "$b/%_datadir/ffmpeg"
564
%endif
565
566
# Install private headers required by libav-tools
567
for i in libavformat/options_table.h libavformat/os_support.h \
568
  libavformat/internal.h libavcodec/options_table.h libavutil/libm.h \
569
  libavutil/internal.h libavutil/colorspace.h libavutil/timer.h \
570
  libavutil/x86/emms.h libavutil/aarch64/timer.h libavutil/arm/timer.h \
571
  libavutil/bfin/timer.h libavutil/ppc/timer.h libavutil/x86/timer.h; do
572
    mkdir -p "$b/%_includedir/ffmpeg/private/"`dirname $i`
573
    cp -a $i "$b/%_includedir/ffmpeg/private/$i"
574
done
575
576
%post   -n libavcodec57 -p /sbin/ldconfig
577
%postun -n libavcodec57 -p /sbin/ldconfig
578
%post   -n libavdevice57 -p /sbin/ldconfig
579
%postun -n libavdevice57 -p /sbin/ldconfig
580
%post   -n libavfilter6 -p /sbin/ldconfig
581
%postun -n libavfilter6 -p /sbin/ldconfig
582
%post   -n libavformat57 -p /sbin/ldconfig
583
%postun -n libavformat57 -p /sbin/ldconfig
584
%post   -n libavresample3 -p /sbin/ldconfig
585
%postun -n libavresample3 -p /sbin/ldconfig
586
%post   -n libavutil55 -p /sbin/ldconfig
587
%postun -n libavutil55 -p /sbin/ldconfig
588
%post   -n libpostproc54 -p /sbin/ldconfig
589
%postun -n libpostproc54 -p /sbin/ldconfig
590
%post   -n libswresample2 -p /sbin/ldconfig
591
%postun -n libswresample2 -p /sbin/ldconfig
592
%post   -n libswscale4 -p /sbin/ldconfig
593
%postun -n libswscale4 -p /sbin/ldconfig
594
595
%if %{with ffmpeg3_full_build}
596
%files
597
%doc CREDITS README.md
598
%_bindir/*
599
%_mandir/man1/ff*.1*
600
%_datadir/ffmpeg/
601
%endif
602
603
%files -n libavcodec57
604
%_libdir/libavcodec.so.*
605
606
%files -n libavdevice57
607
%_libdir/libavdevice.so.*
608
609
%files -n libavfilter6
610
%_libdir/libavfilter.so.*
611
612
%files -n libavformat57
613
%_libdir/libavformat.so.*
614
615
%files -n libavresample3
616
%_libdir/libavresample.so.*
617
618
%files -n libavutil55
619
%doc Changelog
620
%license COPYING.GPLv2 LICENSE.md
621
%_libdir/libavutil.so.*
622
623
%files -n libpostproc54
624
%_libdir/libpostproc.so.*
625
626
%files -n libswresample2
627
%_libdir/libswresample.so.*
628
629
%files -n libswscale4
630
%_libdir/libswscale.so.*
631
632
%files libavcodec-devel
633
%dir %_includedir/ffmpeg/
634
%_includedir/ffmpeg/libavcodec/
635
%_libdir/libavcodec.so
636
%_libdir/pkgconfig/libavcodec.pc
637
%_mandir/man3/libavcodec.3*
638
639
%files libavdevice-devel
640
%dir %_includedir/ffmpeg/
641
%_includedir/ffmpeg/libavdevice/
642
%_libdir/libavdevice.so
643
%_libdir/pkgconfig/libavdevice.pc
644
%_mandir/man3/libavdevice.3*
645
646
%files libavfilter-devel
647
%dir %_includedir/ffmpeg/
648
%_includedir/ffmpeg/libavfilter/
649
%_libdir/libavfilter.so
650
%_libdir/pkgconfig/libavfilter.pc
651
%_mandir/man3/libavfilter.3*
652
653
%files libavformat-devel
654
%dir %_includedir/ffmpeg/
655
%_includedir/ffmpeg/libavformat/
656
%_libdir/libavformat.so
657
%_libdir/pkgconfig/libavformat.pc
658
%_mandir/man3/libavformat.3*
659
660
%files libavresample-devel
661
%dir %_includedir/ffmpeg/
662
%_includedir/ffmpeg/libavresample/
663
%_libdir/libavresample.so
664
%_libdir/pkgconfig/libavresample.pc
665
666
%files libavutil-devel
667
%dir %_includedir/ffmpeg/
668
%_includedir/ffmpeg/libavutil/
669
%_libdir/libavutil.so
670
%_libdir/pkgconfig/libavutil.pc
671
%_mandir/man3/libavutil.3*
672
673
%files libpostproc-devel
674
%dir %_includedir/ffmpeg/
675
%_includedir/ffmpeg/libpostproc/
676
%_libdir/libpostproc.so
677
%_libdir/pkgconfig/libpostproc.pc
678
679
%files libswresample-devel
680
%dir %_includedir/ffmpeg/
681
%_includedir/ffmpeg/libswresample/
682
%_libdir/libswresample.so
683
%_libdir/pkgconfig/libswresample.pc
684
%_mandir/man3/libswresample.3*
685
686
%files libswscale-devel
687
%dir %_includedir/ffmpeg/
688
%_includedir/ffmpeg/libswscale/
689
%_libdir/libswscale.so
690
%_libdir/pkgconfig/libswscale.pc
691
%_mandir/man3/libswscale.3*
692
693
%files private-devel
694
%_includedir/ffmpeg/private/
695
696
%changelog
697